Support » Installation » [Resolved] Cannot automatically upgrade to 2.8.6

[Resolved] Cannot automatically upgrade to 2.8.6

  • I use the automatic upgrade feature many times previously without any problem. However, it fails this time with the following message (nothing happen after the line “Unpacking the update.”:


    Downloading update from http://wordpress.org/wordpress-2.8.6.zip.

    Unpacking the update.


    Any clue ?

    Thanks in advance.


Viewing 9 replies - 1 through 9 (of 9 total)
  • BTW, I checked and the zip file was downloaded ok (2,355,239 bytes) to my host … just nothing happened afterward. Also, the permission of the “upgrade” directory is 755 all along.

    try deactivating your plugins first – especially something “unusual” – other than the most common ones. I had the exact problem running the WP e-commerce plugin, the update would stall while it was active.

    after deactivating WP e-commerce, the update went through.


    Apart from it highly inconvenient to have to deactivate all the plugins, this solution did not work for me.

    Unpacking updates
    Could not copy files
    Installation failed

    All folders have full read/write/execute access. Previous updates have been seamless.

    Thanks Andy.

    I disabled all the plug-ins and upgrade again … and it worked. Thanks a lot !! … even though I still don’t know why …

    Many thanks again !!

    Thank you andixx for your suggestion. Worked beautifully for me.

    I suspect that this might be because of your allotted server memory. 1and1 for instance only allows 20MB per account. (Yes, I did say 20MB) So, if you are running plugins that are hitting that limit, your upgrade won’t happen.

    Has anyone else noticed their dashboard missing its toolbar in 2.8.6? My buttons on the dashboard also aren’t working.

    @myung, @a_johnson: I am no PHP guru by all means, but what I suspect is that the plugins call for various core WP engine files that, while being used, can not be overwritten. kind of like trying to delete files in use on your computer. that’s what made me try disabling the plugins.

    perhaps one of the WP experts here can explain that for us.

    andixx, you may be correct but…

    I have never had to disable plugins once I moved to MediaTemple hosting where I have unlimited memory and CPU power. With 1and1, it was a trainwreck trying to do anything. 1and1 is the host that has the 20mb limit on server memory.

    There are all kinds of threads about problems that can be traced directly back to CPU power and memory.

    Also, once I switched to MediaTemple, all the items in the dashboard started working again. With 1and1, they didn’t.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Cannot automatically upgrade to 2.8.6’ is closed to new replies.