Support » Plugin: Twitter Widget Pro » Cannot authorise new account [Request token for this page is invalid]

  • Resolved Tejstar

    (@tejstar)


    I am having problems updating to the latest version of Twitter Widget Pro like many others. I have read all of the threads on here but none of the solutions work for me.

    I get the following error on twitter:

    Whoa there!

    The request token for this page is invalid. It may have already been used, or expired because it is too old. Please go back to the site or application that sent you here and try again; it was probably just a mistake.

    Here are my settings in the Twitter Developer site:

    Name: Entered
    Description: Entered
    Website: Entered
    Application Type: Read only
    Callback URL: Entered
    Allow this application to be used to Sign in with Twitter: Ticked

    On my WordPress site:

    The Consumer key and Consumer secret are both entered. I have also tried resetting these to no avail.

    I’m currently using:

    WordPress – Version 3.5.1
    Twitter Widget Pro – Version 2.5.2

    http://wordpress.org/extend/plugins/twitter-widget-pro/

Viewing 15 replies - 1 through 15 (of 21 total)
  • gkvwezep

    (@gkvwezep)

    This is the same problem as I have. A little bit frustrating.
    I’ve tried the plugin Twitter Stream and that one has not this problem with authorizing.

    But I like this plugin much more… So I hope the developers can use some code from Twitter Stream…?

    Tejstar

    (@tejstar)

    I see there has been a new update – Version 2.5.3.

    I updated to this version and I still have the same issue as before. This is a frustrating bug.

    Plugin Author Aaron D. Campbell

    (@aaroncampbell)

    The only other person that I saw with this problem said it turned out to be a plugin conflict. Can you disable all other plugins and try again? If it works, enable your plugins one at a time and let me know which one was conflicting.

    Tejstar

    (@tejstar)

    Thanks for the reply Aaron. Unfortunately I have already tried disabling all plugins with no success.

    It seems bizarre what can be causing the problem, especially as others have it working.

    alexo05

    (@alexo05)

    Hello Aaron

    I too am experiencing this issue. When I setup the application, include the proper tokens in the correct fields, I click on the authorize account button and I get this page:

    Whoa there!
    The request token for this page is invalid. It may have already been used, or expired because it is too old. Please go back to the site or application that sent you here and try again; it was probably just a mistake.

    I suspect this could be a Twitter issue because even if I try the twitter widget from inside my own profile, it doesn’t display any tweets.

    Hope this helps.

    Dirty Bill

    (@dirty-bill)

    Same issue. I’m running this on a development system with no other Twitter plugins, no facebook plugins. Token is invalid or expired.

    Plugin Author Aaron D. Campbell

    (@aaroncampbell)

    There are several reasons a non-Twitter plugin could break things. The most common would be anything oAuth related or a caching plugin. But any plugin modifying URLs could as well. Try disabling all your plugins and testing (not just certain ones)

    Dirty Bill

    (@dirty-bill)

    The dev site runs nothing that uses oAuth. Some custom post types components, but that’s about it. Besides, if it doesn’t work with the few components that are plugged in, there’s something wrong with your plugin. All of the ones on Dev are in use on Production without conflicts.

    Could it be a problem with the new Twitter API?

    gkvwezep

    (@gkvwezep)

    I had this problem also. I installed Twitter Stream wich had the same procedure. This one works without any problems. So there is something different between these plugins. I still hope that the developers of Twitter Widget Pro can solve this problem soon.

    I think I have this problem too – but I get “Could not recognize the response from Twitter”.
    Is this the same issue?
    New install, no other plugins

    actionPackedAndy

    (@actionpackedandy)

    I’m having the same issue as emma@glic.me

    “Could not recognize the response from Twitter”

    Actually – my bad. I left the callback url blank. So I went back and put in my own url and it worked like magic.
    Now if only I can get the shortcode to work 🙂

    See http://wordpress.org/support/topic/instructions-for-non-tech-ppl-for-twitter-authorization-issue

    Thanks emma@ glic.me, it works!

    Plugin Author Aaron D. Campbell

    (@aaroncampbell)

    Can everyone else in this thread triple-check that they set a VALID callback URL? Just use your site URL.

    susandbecker

    (@susandbecker)

    Same thing was happening to me. I noticed that when I copied and pasted the Consumer key and Consumer secret from Twitter, I picked up some extra white-space before the key/secret. I deleted this in the plugin’s settings fields and it now works.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Cannot authorise new account [Request token for this page is invalid]’ is closed to new replies.