WordPress.org

Forums

myCRED
[resolved] Cannot adjust user totals (10 posts)

  1. chickster25
    Member
    Posted 1 year ago #

    Hi,

    This is a great plugin and really good for awarding loyalty points to our users, but we have found that we cannot adjust user totals in wp-admin.

    At our auction website http://www.redooce.com, When a user reaches 100 or more points we will convert 100 points to £1.00 , therefore we would need to reduce their points total back to zero.

    But when we try to adjust the total, a pop-up box appears but does not contain any of the user ID information and when we click "update" nothing happens.

    We really need to get this working or our whole loyalty points concept will not work

    Thanks

    http://wordpress.org/plugins/mycred/

  2. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    Hi.

    Sounds like you are trying to "reset" a users balance under Maintenance on the myCRED > Settings page. If thats the case, you are attempting to zero out ALL users balances and not just one users.

    You can adjust all users balances individually on the Users page in the admin area. Find the user in question, hover the mouse over their row and in the "Points" column you will find two new options: "History" (shows that users history on the log page) or "Adjust" opens a modal window where you can adjust a users balance.

    If you want to change the users balance to zero, you could just deduct the exact amount they have on their account.

  3. chickster25
    Member
    Posted 1 year ago #

    Hi,

    I am trying to do it through the Users page in the admin area, but it does not load the users name into the pop-up box and when I put in a number and click update, nothing is changing.

  4. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    Do you get any javascript errors in your browsers console when viewing the Users page? Could be that the manual editor script is colliding with some other script that is being loaded on the same page.

  5. chickster25
    Member
    Posted 1 year ago #

    Hi,

    I cannot see any errors being reported. I am willing to give you a temporary admin account if you would like to have a look directly at the site, all you need to do is register and let me know the username?

  6. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    I registered with the mycred.me support email

  7. chickster25
    Member
    Posted 1 year ago #

    Hello
    sorry for not getting back to your sooner, was offline. I have made you an admin of the site now.

    I have also noticed that the user exclude option does not seem to be working either.

    thanks for your help

  8. chickster25
    Member
    Posted 1 year ago #

    hello Gabriel,

    I was just wondering if you would still be able to help us with this?

    thanks

  9. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    Hi.

    Could you please contact me via the email I used to signup on your website? Please also include any error messages you get if you enable WP_DEBUG that is myCRED related.

  10. chickster25
    Member
    Posted 1 year ago #

    Hi,

    I have emailed you the details. There are no errors in wp_debug relating to MyCRED.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • myCRED
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic