Support » Fixing WordPress » cannot add tags or categories

  • hi all,

    i can’t add tags or categories on my wordpress. i’m running it on my localhost.

    for tags, it gives me this error – “An error has occured. Please reload the page and try again.”

    for categories, it gives me this error – “Could not insert term into the database.”

    this is not a plugin issue because none are activated, and the same error occurs when i try different themes.

    thanks for your help!

Viewing 9 replies - 1 through 9 (of 9 total)
  • bump!


    still can’t resolve this issue. i’ve been searching through the archives, and came across a tip to “resetting the plugins folder by FTP or phpMyAdmin”.

    i’m following the instructions from here –

    but in the table wp_options (using phpMyAdmin), under the option_name column (field), there is no active_plugins row???

    I’m getting this error too. I upgraded wordpress mu 2.92 to wordpress 3.0 and now I cannot categories. The weird part is I was able to add 2 categories and then after trying to add a 3rd one, I got the same error as above.

    Anyone know a fix for this?

    This problem has just occurred for me too, quite unexpectedly. I have added a bunch of categories, inlcuding subcategories, and now I am getting the error msessage:-

    “Could not insert term into the database”

    – when I try to add a new category.

    I am using WordPress 3.0 (single user).

    If anyone understands what causes this or knows a work around or fix, please share it.

    Having the same issue, cannot add category at all. When I clicked the Add Category button, nothing happened. I’ve tried deactivating all plugins but the problem still persist.



    Got the same problem, as described by silverks. Have added categories before, now the Add button is non-responsive. Had upgraded to 3.0, then downgraded back to 2.9.2. Any advice would be greatly appreciated!!


    The only fix that I know of is to go into the WordPress database, edit the terms table and add a blank row. Add some content in one of the cells and then delete the row completely (to keep things clean). Go back to your admin and now you will be able to add categories from the admin.

    This happened to me when I upgraded from mu to wordpress 3.0. I don’t know how else to fix this.

    Hope this helps a bit.

    sewetee, I can confirm that this works (at least, it did for me with my WP 3.0 running multisite). Was having problems creating categories on a child site, with the same error: “Could not insert term into the database.” Using the SQL command line client–you could do the same with the phpMyadmin GUI if your database isn’t too large, btw–I used the following commands to add/delete a record from the wp_xx_terms table:

    To insert the record:

    insert into wp_[**blog id here**]_terms (term_id, name, slug) values ('[new term id value]', '[new name value]', '[new slug value]');

    … and then to delete the record:

    delete from wp_[**blog id here**]_terms where term_id=[new term id value];

    For the record, I only provided values for term_id, name, and slug per instructions I found on another thread (there is one more field in that table; I forget what it is at the moment). Also, as a disclaimer, the queries were run in a WAMP environment, so your syntax could very well vary–but this is at least ballpark.

    It’s also worth mentioning that I did the standard stuff when I first noticed the error: changed the theme, tried to deactivate plugins, etc. Anybody know if Andrea_R has any thoughts on this? I’m not seeing any confirmation of a bugfix anywhere, but plenty of posts reporting the same error–some old, some newer.

    I have no idea technically speaking why this fix works. If anyone can enlighten us, that would be fantastic!!!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘cannot add tags or categories’ is closed to new replies.