Support » Plugin: Team Rosters » Cannot add player

  • Resolved iggyvolz

    (@iggyvolz)


    I am trying to add players to my site and it seems to save properly but the player is not visible anywhere, including in “All Players”.

    I go to “Add New Player and fill out the fields such as First Name, Last Name, et cetera. Some of the fields are not applicable so I leave them blank, as well as the post title and post data. Pressing submit leads me to believe everything saved properly, but the link I am given leads to a 404. The player is also not visible in “All Players”.

    Looking deeper into the database, it seems the post is saved there correctly with the ID I am given in the link from the page. post_date is set to the time I submitted, but post_date_gmt is set to 0000-00-00 00:00:00. post_content is understandably blank, and post_title is Auto Draft. post_status is auto-draft, leading me to believe the save did not go through properly.

    Any ideas on why the player shows up nowhere on my site? Should it not save as auto-draft?

    https://wordpress.org/plugins/team-rosters/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Setting post_status to publish makes “Auto Draft” show in my “All Players” view.

    Plugin Author Mark O'Donnell

    (@markodonnell)

    Hi iggyvolz,
    Interesting. Can’t say I’ve seen that one before …

    It’s possible that the plugin is doing something with auto-drafts since it has to recognize (and not validate/save) autodrafts. But I doubt that’s the problem because I haven’t seen it before now and it doesn’t quite sound like your problem. Have you looked at your WP error log? [wp-content/error.log]

    Let me know.

    -Mark

    I do not have my httpd configured to write error logs out to the folder but rather I have it configured to send everything to the global error log, where there is nothing related to my wordpress there. wp-content/error.log does not exist.

    Plugin Author Mark O'Donnell

    (@markodonnell)

    Okay. The WP error log is not the same as the httpd error log.

    I suggest you set that up. There are many posts on the web telling you how. There’s even one such post on shoalsummitsolutions.com.

    Let me know.
    -Mark

    Odd… it now seems to be working afer I set up the debugging as you asked. It may be related to the fact that I changed my URL scheme from the default to Day and Name, or the 4.1.1 upgrade.

    I’ll mark this as resolved unless the issue comes back.

    Plugin Author Mark O'Donnell

    (@markodonnell)

    Cool. Note that if your permalinks are not set to POST NAME, single player pages (bios/profiles) and player gallery (pages) are not going to work. That’s explained in the users manual.

    -Mark

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Cannot add player’ is closed to new replies.