WordPress.org

Support

Support » How-To and Troubleshooting » Cannot add new post

Cannot add new post

  • site- http://www.mediabreach.com I was using 2.9.2 and in an attempt to fix this issue I updated to 3.2.

    This morning out of nowhere, I find that when I try to Add a Post, I get a message that “You are not allowed to edit this post.” With 2.9.2 it would just send me back to the posts directory. I tried deleting a post to see if it was full but that didn’t work.

    I believe this may have been malware caused but I cannot figure out how to fix it. As it is, my blog works but I cannot add posts. I did notice with 2.9.2 that there was what looked like an advertisement posted in the middle of one of my posts but it appears to be gone with 3.2. I know there is information that I’m leaving out here but I’m pretty desperate for assistance. Please let me know what else you need to know and I’ll be glad to provide it.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Just to add-

    changing theme or disabling all plug-ins did not help. My database was reportedly over the limit due to an issue I have with the Pro Player plug-in but I cleared the database and the usage is back to normal (this is just something I’ve had to do).

    Again, let me know if you need more information.

    Try running a repair on the database.

    I’m a complete newb- how does one run a repair on the database?

    I tried running a repair on a few individual tables in the phpMyAdmin and it gave me this error-

    #1142 – INSERT command denied to user

    I have an email in to my hosting service to see what’s up but any other advice is appreciated.

    Yeah, that would be the next step. Sounds like when you cleaned up your DB something went odd.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Cannot add new post’ is closed to new replies.
Skip to toolbar