Support » Fixing WordPress » Cannot add new pages, update existing ones, occasionally affects posts too

  • Website in question:

    There’s an issue I’m having with WordPress. I’ve not used my website for a while, when I came back I wanted to update the pages and add some new ones.

    When I got back, WordPress had an update available to version 3.0.1. I used the auto-update feature in the Dashboard to install this. After posting a shitload of regular blog posts, that all went without a hitch, I went to create the first new page. (the 101 in 1001 ). I created it as a placeholder page first. I published this page, and that went without problems.

    A while later I wanted to edit the page to put the actual content in, and now every time I try to edit that page, it times out on me. I get the dreaded “The connection to the server was reset while the page was loading” thing. Refreshing makes no difference, it just keeps on timing out. Trying to update with less content (the list is rather long) makes no difference either. About this time I noticed posting new pages, in addition to editing existing ones, was also not happening. Even posting blog posts sometimes times out.

    Thinking the update hadn’t gone right, I then manually replaced all the files with the updated 3.0.1 files. Still no change. I tried changing the permissions on the post.php file to make it not just read-write-executable by admin, but also read-write-executable for group and public. This didn’t help either, so I changed that back.

    So then I hit Google to try and figure this out, however I can’t find anything. Well, I found, somewhat applicable, but that was a couple versions ago. That person edited the .htaccess file. I tried both edits described in the link, but no luck.

    I also looked through my hosting providers’ FAQ, they mentioned a line AddHandler x-httpd-php5 .php to add to the .htaccess file to make php be parsed by PHP 5 (since they have both 4 and 5 installed and supported). Tried that, no luck.

    So, here I am, stuck. I contacted my hosting provider with this (no response yet), to see if it’s something server side, and I’m posting it here to see if there are some bright minds over there who can help me figure it out.

    Plugins used: Akismet, Quotes Collection, Yet Another Photoblog and YAPB Sidebar Widget

Viewing 9 replies - 1 through 9 (of 9 total)
  • Damn, affecting posting regularly now, instead of occasionally :S

    Plus, what I just noticed, the post I was trying to publish did appear, but only half of it. It seems like the time-out cut the post in half.

    Hmm… still no progress. I tried it with the default 2010 theme to see if my theme was to blame, no change.

    Disabled all my plugins, (and deleted all the ones I wasn’t using with an FTP program), no change.

    Changed permalinks back to the standard (I had it set to year/month/post-title), no change.

    I can post things pretty well (will still occasionally time out, but will work when retrying), but still not edit existing pages or add new pages.

    You might check to see if any of your database tables need to be repaired – I’ve been seeing quite a few corrupt post tables lately (specifically on hostgator – not sure who your host is). I dont know that that would explain your problem, but it can’t hurt to try.



    No luck 🙁

    Repaired all the tables my database has, but no luck.

    It would take one page edit when I changed the 2 paragraphs or so of text into “try out”, but then when I tried to edit it again, and put in the text that was there, it times out again.

    However, when I add a new page, for testing, with new text, it now does take. And that I could edit as well. I kept editing it, adding another 100 words of text and it kept taking until I stopped it myself at 2100 words.

    So that leads me to thinking there’s something in the text I want to add that WordPress disagrees with as it has near 1900 words now, so it can’t be that WP doesn’t like long text… So I stripped all formatting from my wanted content and tried it as plain text.

    It still doesn’t work. Not when I edit the original page, remove what’s in there and add the stripped raw text. And not when I edit the test page I created ^. And not when I create yet another new page…

    I’m so totally stumped :S



    I retyped the entire content I was having trouble with. It works now. However, the moment I try to add colour to the text, it times out again. Might be useful to know as another defining symptom.

    Peter Butler


    I’m afraid I’m completely stumped too. Have you tried tracking down your error log to see if anything is showing up in there?



    Ooh, something new for me. Where do I find the error log?



    Yes I solve this problem.. go to wordpress permalink option and change your cuntom permalink structure to %postname% to %post_id% this will solve your problem.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Cannot add new pages, update existing ones, occasionally affects posts too’ is closed to new replies.