Support » Fixing WordPress » Cannot add “New Page”

  • Resolved fain360

    (@fain360)



    When clicking on Pages>Add New, I type in a title and some text in the paragraph box. Then I click on Save Draft. I get the message: Updating failed.
    I click on Preview and get a page that says “Generating Preview” in a never-ending loop.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Moderator t-p

    (@t-p)

    What did you do before this issue?

    fain360

    (@fain360)

    I just signed up with Bluehost and accessed WordPress from there. I don’t know of anything specific that I did before WordPress stopped working.
    I get the error as I said above, but I don’t get any other info (pop up message or whatever) from WordPress about the cause or solution.

    fain360

    (@fain360)

    Also, even though I get an error when I try to save and an error when I try to publish and a preview screen that never populates, something is happening. When I go to leave the “Add Page” section I am told I will lose all my info. I say okay. I go to “All Pages” and I have a new page called “Auto Draft – Draft”. When I go into it, it does not have the title or any info I put in. In the title line is just “Auto Draft”.

    So, somehow a draft page is being created.

    Moderator t-p

    (@t-p)

    Are you using the NEW Block Editor (Gutenberg) that came with WP5 or are you using the old Classic editor?

    fain360

    (@fain360)

    When I first log in, I get the “Welcome to WordPress 5.0.3” screen. I don’t see anything called Gutenberg. I just go from that front page to the Pages button on the left.

    Moderator t-p

    (@t-p)

    First of all, make sure you have not disabled the REST API by a plugin or a snippet.

    fain360

    (@fain360)

    Based on an article I found earlier, I disabled all plugins, but the error continued.
    How can I confirm if REST API is enabled?

    Moderator t-p

    (@t-p)

    If you can install plugins, install “Health Check”: https://wordpress.org/plugins/health-check/ On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    This plugin can also test REST API

    fain360

    (@fain360)

    Health Check says:

    REST API availability The REST API call gave the following unexpected result: (401) {“code”:”rest_forbidden_context”,”message”:”Sorry, you are not allowed to edit posts in this post type.”,”data”:{“status”:401}}.

    Moderator t-p

    (@t-p)

    I’m not sure.

    Let me ask around in the backroom

    Moderator t-p

    (@t-p)

    The REST API call gave the following unexpected result

    It’s a bug, it’s being fixed this evening.

    Other way to check your Rest API:

    – There are some plugins that can disable REST API. Make sure you are not using one of those.

    – Any code snippet

    New Page is working again. Thanks!

    Moderator t-p

    (@t-p)

    You are welcome 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.