Cannot add new item in menu (pending) (5 posts)

  1. aztuk
    Posted 3 years ago #


    I'm really new at wordpress and it's the first time i try to make a website with that.

    Today, when i logged in, i was inserting pictures to my media library. Then, i wanted to attach pictures to pages/posts and it didn't work.

    When i preview the page/post, i saw menu had only one item instead of five. So i went to Appearance > Menu.

    I tried to add pages, custom links to the menu but it always appears to be (pending).

    I tried the following but no results:

    - Reinstall (in Dashboard -> updates)
    - Go in phpmyadmin and REPAIR TABLE ... USE_FRM for all tables
    - Deactivate all plugin and then reactivate them
    - Delete pictures one by one (massive deletion doesn't work either)

    Please help me :s

  2. jmarchan
    Posted 3 years ago #

    Same issue here. did you solve it?

  3. JanChadaj
    Posted 3 years ago #

    Same problem here - been looking all day and all forum threads are closed without an update on the solution.....
    Some hints at a corruption in table wp_postsmeta - but I don't have that table.

  4. canyonblvd
    Posted 3 years ago #

    I had this problem, and at least for me it ended up being because the postmeta table in the database was somehow corrupted.

    I solved it (this worked for me but might not for you) by getting the default table wp_postmeta from a newly installed wordpress database. I set up a dummy WordPress site just so I could get at the default database that WordPress sets you up with.

    I then exported/saved the wp_postmeta table from the default database onto my computer, and then imported/uploaded this file onto my website database that didn't work.

    It immediately let me add pages like before.

  5. srikant_mft
    Posted 3 years ago #

    Thanks canyonblvd your trick works for me..

Topic Closed

This topic has been closed to new replies.

About this Topic