WordPress.org

Support

Support » How-To and Troubleshooting » Cannot Add New Custom Fields

Cannot Add New Custom Fields

  • I upgrade a few sites to 3.4.2 and I cannot add a new custom field on these sites. Input everything and click enter and it just hangs.

    All of my 3.4.1 still work fine.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hi BrentS!

    Yes this bug has been confirmed and is being worked on.

    http://core.trac.wordpress.org/ticket/21829

    Edit: I see there is already a patch so go ahead on the link and use the patch.

    Regards

    never used a patch. I see it, but do not have a clue where I should add it.

    save the patch file in your plugin directory, that should do it.

    I uploaded the php file into /wp-content/plugins folder and no change

    I am trying to use this fix

    SergeyBiryukov —

    attachment fix-custom-fields-in-wp342.php

    but it is not doing anything.

    Still have not determined how to use the patch or make it work. I placed in the folder that jnhghy suggested but nothing.

    Moderator Sergey Biryukov

    @sergeybiryukov

    WordPress Dev

    I uploaded the php file into /wp-content/plugins folder and no change

    Have you activated it on the Plugins screen?

    The fix is also going to be available in the upcoming Hotfix 0.9 release:
    http://wordpress.org/extend/plugins/hotfix/

    Johanhorak

    @johanhorak

    I tried this and it does not work for me.

    Tried installing the hotfix plugin. It had no effect. New custom fields seem to be created, but do not appear when published. Others that are on the published live page are not in the custom field area in the back end so I can’t even change them.

    Big problem.

    The update button hows up, but it does not work. I try to change a price. Even though there is a sale price working, there is no “new_price” custom field on the back end. When I try to create a new “new_price custom field, it updates but after updating the whole page, it just reverts back to the original sale price…even though that field was not even on the backend page when I started. UGH!

    I got this issue fixed.

    1) I have the hotfix but it did not work on it’s own.

    2) I opened the screen options and untagged Custom Fields. Closed the screen, opened it again and tagged it again.

    3) I then created a Custom Field and left the cursor in the field and pressed enter on my computer.

    And it was all fixed.

    Which of these worked?

    I have no cooking clue.

    BTW: Method (3) is not my invention. I saw this via another discussion here at the forum where a user suggested this.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Cannot Add New Custom Fields’ is closed to new replies.
Skip to toolbar