Support » Plugin: WordPress Button Plugin MaxButtons » Cannot Add New Button

  • I have been using MaxButtons for years; and our site recently migrated to a new domain name. Now I find I cannot Add New. I get these error messages:
    Maxbuttons button id is zero. Your data is not saved correctly! Please check your database.
    MaxButtons could not find this button in the database. It might not be possible to save this button! Please check your database or contact support!

    I found an earlier thread about the identical problem (now closed) but could not complete your instructions:
    “Something is wrong with your database. Did you just install the plugin? You can try to deactivate the plugin and activate it again.” I tried deactivating/reactivating. I deactivated and deleted, then reinstalled. Still the same error messages.
    “If the problem is still there however you should check your database and the permissions. Maybe the database user is not allowed to create tables, which is needed for the plugin.” Can you be more specific about which permissions to check, and where they might be found in the database? I am not a technical person, so will need some detailed help with this.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author Bas Schuiling

    (@basszje)

    Hi,

    Could you check which version of the plugin you are using? I’d recommend upgrading to the latest one if that’s not the case.

    Please also check your PHP version on that site and check if anything is wrong with WP in general ( correct settings for domain, database prefix etc ). I’m surprised because it’s been years since somebody had this error.

    The table the plugin is trying to create, update and use is called ‘maxbuttonsv3’, with your database prefix before it ( default is wp_ ) .

Viewing 1 replies (of 1 total)
  • The topic ‘Cannot Add New Button’ is closed to new replies.