Support » Plugin: Meta Tag Manager » Cannot add meta tags to individual posts

  • I’m trying to add a custom meta tag to an individual post (as shown in the screenshots.) I’ve tried just plane looking at the posts page, and adding an appropriately named meta tag with a blank content attribute. Neither has caused the third screenshot’s GUI to appear on the post page.

    What’s up with this?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Marcus

    (@netweblogic)

    Hi, can you be more specific as to what you’re trying to add? e.g. tag name values. a screenshot may help.

    I tried adding a <meta name="test content="" /> to a post I had created before on my test site and that worked.

    Also, have you tried doing this with other plugins temporarily disabled, or temporarily switching to a default WP theme?

    dluxcru

    (@dluxcru)

    I’m trying to figure out how to add a meta tag for an individual post. I think general usage instructions would be a start, because that seems to be my sticking point. Where do I find the controls seen in the third demo screenshot for your plugin?

    Plugin Author Marcus

    (@netweblogic)

    Sorry we don’t have any detailed docs atm.

    When editing or adding a post, you should see that meta box.

    If not, make sure the post type you’re trying to edit is included by going to Settings > Meta Tag Manager > General Options (Tab) and add it to the ‘Post Type Support’ field.

    If you don’t see it after saving that setting, click ‘screen options’ and make sure ‘Meta Tag Manager’ is checked.

    dluxcru

    (@dluxcru)

    I have that setting saved for the post type. Meta Tag Manager does not appear in “Screen Options” – there is no checkbox for it. (You just pointed me to a whole new set of setting I didn’t even know about there!)

    Plugin Author Marcus

    (@netweblogic)

    Could you try disabling other plugins and/or switching themes temporarily to see if that helps? If the post type is showing on our settings page, then it should be showing up.

    I’d also say to double check as sometimes the meta boxes are easy to miss or mix up e.g. maybe it’s closed and you need to click to expand the contents.

    This is a production site so disabling plugins/changing themes is ill advised until at least summer or maybe part of spring break. (Education sites are easier to downtime in for summer, at least for us.). I’m afraid I don’t really have the benefit of a test site. I can send you the theme and a plugin list if you have a test site and want to look into the matter. A plugin list in case any are known to cause problems (Many are outdated until the summer upgrade).:

    All-in-One Event Calendar by Time.ly v2.2.0 By Time.ly Network Inc.
    CKEditor for WordPress v4.4.5 | By CKSource |
    Database Browser v1.2 | By Chris Taylor |
    Facebook Like Thumbnail v0.4 | By Ashfame |
    Google Analytics Version 1.0.5 | By Kevin Sylvestre
    Huge IT Slider Version 3.0.6 | By Huge-IT
    Meta Tag Manager Version 2.0.2 | By Marcus Sykes
    PhotoSmash Version 1.0.7 | By Byron Bennett |
    Responsive Flickr Gallery
    Version 1.3.0 | By Lars Schenk
    Share Buttons by AddToAny Version 1.5.2 | By AddToAny
    Team Members Version 2.1.2 | By WP Darko |
    Ultimate Social Media PLUS Version 2.2.1 | By UltimatelySocial
    YouTube Version 11.5 | By EmbedPlus Team

    WordPress V 4.1.15
    Theme
    Peacekeeper By Jinsona Designs
    We have some custom code in there, many replacing the slider with a plugin (Flash broke) and tweaking the nav bar.

    Plugin Author Marcus

    (@netweblogic)

    I’m not aware of any conflicts with MTM. None of these stand out either, the most suspect to me would be your theme, but that’s just a guess as I don’t know it and the others don’t sound like they mess too much with meta boxes.

    Does it show up for posts and pages at least? That should work out the box…

    I understand that it’s hard to debug the live site. Unfortunately without testing that first I can’t really help further as we could go round in circles and it turns out to be a plugin/theme conflict. Same with custom code. I’d suggest making a backup and reproducing/debugging it on a test site.

    • This reply was modified 3 months, 4 weeks ago by Marcus.
    Plugin Author Marcus

    (@netweblogic)

    Oh… I just noticed…. are you running WordPress 4.1? If so, then that may well be the problem too… I haven’t tested backwards compatibility for a while, not that it shouldn’t work with 4.1, it should work with versions since introduction of CPTs which I think was earlier.

    I’ll have to figure out how to backup a custom theme. If you have any pointers on how to do that I’d welcome it.

    Plugin Author Marcus

    (@netweblogic)

    this is the best place to start – https://codex.wordpress.org/WordPress_Backups

    there’s loads of plugins to help out with that free and paid

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.