Support » Plugin: Sublanguage » Cannot add language

  • Resolved bkkjim

    (@bkkjim)


    I am using Sublanguage with Pods, and started having an out-of-memory error when accessing translated content, even with a 512M php limit. I decided to remove Sublanguage and content and do a clean rebuild, so deleted the languages then the plugin, per instructions, then reinstalled. However now when activated there is no Languages post type shown, and the “Add Language” link in the settings page throws an “Invalid post type” error.

    WordPress 5.2.3, multisite.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello,

    Please try to go in settings > Sublanguage and click save.

    Thank you for your reply, Maxime. Clicking save in Sublanguage setting still did not change the behavior.

    I found a fix: the fact that there was nothing at all showing in the Original Language dropdown in Sublanguage gave me a clue. I went to General settings for the site, changed the site language to another one, then back to English. Then I deactivated and reactivated Sublanguage and the Languages custom post type did appear.

    Thank you for these informations, I’ll try to fix this issue.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Cannot add language’ is closed to new replies.