WordPress Gallery Plugin MaxGalleria
[resolved] Cannot add images to galleries after upgrade (19 posts)

  1. fi
    Posted 2 years ago #

    After the most recent update, I can't seem to add any images, either to a new or existing gallery, although it was all working fine last time I used it a couple of weeks ago. Now when I try to add images, I get a message that "There was a problem adding the images to your gallery."

    I've tried adding via uploads and from images already in the media library, and also checked in two browsers, with the same result.

    Any ideas? Thanks.


    ----- Begin System Info -----

    WordPress Version: 3.9.1
    PHP Version: 5.3.28
    MySQL Version: 5.5.35
    Web Server: Apache/2.4.9 (Unix)

    WordPress URL: http://www.bramblepatchonline.com
    Home URL: http://www.bramblepatchonline.com

    PHP cURL Support: Yes
    PHP GD Support: Yes
    PHP Memory Limit: 256M
    PHP Post Max Size: 64M
    PHP Upload Max Size: 64M

    WP_DEBUG: Disabled
    Multi-Site Active: No

    Operating System: Mac
    Browser: Google Chrome 35.0.1916.114
    User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.114 Safari/537.36

    Active Theme:
    - Headway Base 3.5.13

    Active Plugins:
    - All-in-One Event Calendar by Time.ly 2.0.9

    - Alpine PhotoTile for Instagram

    - BackupBuddy

    - CM Enhanced Tooltip Glossary 2.1

    - Comprehensive Google Map Plugin 9.0.20

    - Configurable Tag Cloud 5.2

    - Display Widgets 2.03

    - Flexible Posts Widget 3.3

    - GC Testimonials 1.3.2

    - Google XML Sitemaps 4.0.5

    - Gravity Forms 1.8.8

    - Hotfix 1.0

    - Jetpack by WordPress.com 3.0.1

    - jQuery Colorbox 4.6

    - Limit Login Attempts 1.7.1

    - MainWP Child 0.29.5

    - Manual Control for Jetpack 0.2

    - MaxGalleria 2.2.1

    - NextGEN Gallery 1.9.13

    - Pizazz ExcerptsPlus (Headway 3 Block) 3.4.4

    - PizazzWP HeaderPlus (Headway 3 Block) 1.2.13

    - PizazzWP Libraries 1.5.0

    - Ultimate Tag Cloud Widget 2.7.2

    - Use Google Libraries 1.5.2

    - Websimon Tables 1.3.4

    - WordPress Hashcash Extended 4.7

    ----- End System Info -----


  2. mainwp
    Posted 2 years ago #

    We have not had any other users report this yet, and are not able to duplicate the issue here. I do not see anything that jumps out at me from your system information provided above.

    If you go to your Dashboard and to Server Information, is there anything in your error log tab?

    Do the child sites allow an image post from themselves?

  3. fi
    Posted 2 years ago #

    In the meantime, I've done several plugin updates, including to the latest MaxGalleria version 2.2.2. Still getting the same error from MaxGalleria on trying to add images to a gallery. Existing galleries are still there, but no new images can be added.

    @mainwp, I'm sorry, I don't understand your question re: child sites. I can't see anything in the error logs relating to Maxgalleria, although there are errors coming from two other plugins, eg,

    bramblepatchonline.com [Mon Jun 02 11:34:45 2014] [error] [client] AH01215: PHP Warning: Missing argument 2 for wpdb::prepare(), called in /home/sites/bramblepatchonline.com/public_html/wp-content/plugins/TooltipPro/synonyms.php on line 80 and defined in /home/sites/bramblepatchonline.com/public_html/wp-includes/wp-db.php on line 1147


    bramblepatchonline.com [Mon Jun 02 11:33:51 2014] [error] [client] AH01215: All-in-One Event Calendar: Undefined variable: xguard @ /home/sites/bramblepatchonline.com/public_html/wp-content/plugins/all-in-one-event-calendar/lib/calendar-feed/ics.php:287 #8

    Sorry for being so slow; I'm just a user not a coder of any kind, so I'm afraid I'm not really sure what I'm looking for...

  4. mainwp
    Posted 2 years ago #

    Have you tried disabling the 2 plugins with errors that you mentioned above temporarily to see if you are then able to post an image?
    TooltipPro & All-in-One Event Calendar

  5. arcware
    Plugin Author

    Posted 2 years ago #

    It could be a possible javsscript conflict with another plugin, but I can't be sure without seeing it. If you'll allow me to login to your WP admin that would help me see things better. Send credentials to dave AT maxfoundry DOT com.

  6. fi
    Posted 2 years ago #

    Hi again

    @mainwp Yes, tried that with no effect, I'm afraid. Same error.

    @arcware Thanks for offering to take a look - I've sent you login details as requested.

  7. arcware
    Plugin Author

    Posted 2 years ago #

    Can you verify with your webhost that your website has write permissions on the wp-content directory?

  8. StarrCarr
    Posted 2 years ago #

    I am also having this issue. I don't have any of the same plugins. I disabled each plugin to see if it corrected the error and it did not. I also disabled 2.2.2 and installed the 2.2.1 version and tried that and it also wouldn't let me add images.

  9. fi
    Posted 2 years ago #

    Just checked - permissions on wp-content directory are 755

  10. arcware
    Plugin Author

    Posted 2 years ago #

    OK, 755 is expected. Still troubleshooting...

  11. arcware
    Plugin Author

    Posted 2 years ago #

    I see where it's failing, just not sure why yet.

  12. arcware
    Plugin Author

    Posted 2 years ago #

    I did some more digging and found that the following error occurs when trying to download a new or existing image to your site:

    "failure when receiving data from the peer"

    After some searching I found that other WordPress users have seen this and it seems related to a setting or change with their web host, some of which discovered it's because loopbacks had been disabled.

    Relay this information and error message to your web host and see what they say.

  13. StarrCarr
    Posted 2 years ago #

    My hosting is through go-daddy and they say it's due to a blacklist issue. Which makes no sense. I don't know if your hosting is through go-daddy and it's a shared issue. This is through a third part host so they are saying that it's making a real-time backup hence the blacklisting.

  14. fi
    Posted 2 years ago #

    Hi again

    I've been in touch with Heart Internet, who host the site, and this is what they said:

    Thanks for the reply. Loopback connections are disabled on our severs we are not able to enable this.

    If you ask the developer to change the connection type from Http connection to a connection back to the server via the file path this should work.

    However I am not able to completed change to the site for you

    Does that make any sense to you, @arcware?

  15. esmi
    Forum Moderator
    Posted 2 years ago #

    I would never recommend trying to run WordPress when hosted with Heart Internet for precisely this reason. I think you'll end up with nothing but problems like this one.

  16. fi
    Posted 2 years ago #


    We've had more than two years with Heart without problems. This is the first time I've ever needed to contact them about anything at all, not even momentary downtime, so maybe we're just lucky...

  17. arcware
    Plugin Author

    Posted 2 years ago #

    Well, this is unfortunate because HTTP connections are the norm, and there is nothing wrong with a website making HTTP requests to itself. This is the first host we've run into that have loopback connections disabled.

    I suppose we could investigate a workaround, but I can't make any promises at this point, sorry.

  18. fi
    Posted 2 years ago #

    Yes, it is unfortunate... I really like MaxGalleria! But I completely understand your reluctance to faff around with something that appears to be a hosting anomaly. I really appreciate your looking into it for me. I just wish I knew why it suddenly changed from working to not working!

    Meanwhile I'll continue my quest for a gallery plugin we can use with the current setup and make a case for moving somewhere else when hosting comes due for renewal.

  19. arcware
    Plugin Author

    Posted 2 years ago #

    Closing this thread.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic


No tags yet.