Support » Plugin: WooCommerce » Cannot add gateways

  • Resolved raphari

    (@raphari)


    Hi everyone,

    Problem :
    – I seem unable to add new gateways to the checkout page. I am trying to get WooCommerce to show 3 gateways on the checkout page

    Symptoms :
    – I do have multiple Payment Methods enabled under WooCommerce -> Setting -> Payments
    – I only get one buttons that reads “Faire le Paiement” (Make Payment) on the checkout page. When I click on it, it goes to the standard Paypal gateway.
    – If I disable the Standard Paypal gateway, it simply creates the order, it doesn’t to pass through any gateway.

    What I’ve tried :
    – I am using a child theme of Ocean WP, I went through the Customize settings of WooCommerce, and I tried checking and unchecking WooCommerce -> Checkout -> Multi-Steps Checkout / Distraction Free Checkout
    – In theme customization, I tried disabling WooCommerce -> General -> Remove Custom WooCommerce Features
    – I used a custom checkout page under theme WooCommerce/checkout/form-checkout.php which I renamed to to form-checkout_tmp.php to revert back to the default checkout page
    – I renamed also WooCommerce/checkout/form-pay.php to form-pay_tmp.php
    – I navigated through multiple tabs of WooCommerce settings… I didn’t find anything that seems to make WooCommerce only use one gateway
    – I disabled my caching plugin (WP Super Cache)
    – I disabled the following plugins : Checkout Field Editor for WooCommerce, WooCommerce PayPal Checkout Gateway
    – Here’s a list of Woocommerce plugins I DIDNT disable: AJAX Search for WooCommerce, Advanced Custom Fields, Custom Order Status for WooCommerce, WooCommerce ‘Email Money Transfer’ Gateway, WooCommerce PDF Invoices, WooCommerce Services
    – Many other small things that I have tried but I don’t remember 😝

    I have the feeling there’s a setting somewhere that would be like “Only one check out option”,

    Hopefully any one of you guys will be able to help me out, it’s been 2 days I am looking for an answer!

    Thank you so much everyone !

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Joey

    (@jricketts4)

    Hi @raphari,

    It’s always a good idea to try enabling a default theme, such as Storefront or 2019.

    I’ve found that you have display: none !important; being applied to .wc_payment_methods in: /wp-content/themes/oceanwp-child-theme-master/style.css

    You should be able to remove that line of code, then you’ll see this: https://cld.wthms.co/LrNZuR

    Let me know if you have any further questions!

    Thank you,
    Joey

    raphari

    (@raphari)

    OMG Joey, I’m facepalming myself so hard right now !!! What a shame XD

    Thank you so much, I’m make sure to do as you say next time, enabling the default theme and checking my CSS

    Thank you so much again Joey !

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.