WordPress.org

Support

Support » Plugins and Hacks » Ninja Forms » [Resolved] cannot add fields to a form

[Resolved] cannot add fields to a form

  • I’m running ninja forms in WP 3.5 in a test situation and I can create new forms change the settings etc. then I go to ‘field settings’ but when I click on the fields nothing happens. I can hit save field settings and it says it was successful but I am not able to add any fields to my forms.

    I updated the plugin from 1.x version to 2.0.1 but I did not have any forms yet. After upgrading all my plugins yesterday I also updated WordPress to 3.5 and I deactivated all other plugins but no change.

    http://wordpress.org/extend/plugins/ninja-forms/

Viewing 15 replies - 1 through 15 (of 26 total)
  • Plugin Author James Laws

    @jameslaws

    Sounds like there is a jQuery conflict of some sort. What theme are you currently using?

    When you say you can’t add any fields do you mean then when you click on a new field that it doesn’t appear in the left portion at all or that it appears over there but when you click save it disappears?

    Also we’ve seen some strange issues with upgrading where certain initializations don’y occur. You might try deactivating and then reactivating the plugin.

    Let me know if any of that works.

    I mean that when I click on a field on left nothing appears, basically nothing changes on the page.

    I’m using the Roots theme and I forgot to mention that it is a wordpress network install, I don’t know if that would make a difference.

    I have deactivated and reactivated the plugin but that did not make a difference.

    Plugin Author James Laws

    @jameslaws

    Ok, the behavior you’re describing is definitely a jQuery conflict issue and if you disabled all you plugins the culprit is most likely the theme. Try switching to the default theme and see if the issue persists.

    I switched the theme from Roots to twenty eleven 1.5 and turned all plugins off and only ninja forms back on. I also replaced both wp-content and wp-admin and the root files, but I still have the same problem.

    Then I tried it on a local xampp install of wordpress 3.5 with twenty eleven 1.5 and a fresh install of ninja forms and there it works. So somewhere there is a difference and I’m gonna try to find what it is. the first thing I noticed is that the local install where it works is not a wordpress network install but just a single site.

    Plugin Author James Laws

    @jameslaws

    Network sites should factor into it. Ninja Forms would have to be activated on each netwrok site individually but will operate just fine like this.

    Please ket us know if you find anything that we might be able to improve on on our end.

    At the moment there is only one site on my network and it is activated in that site, not network-wide.

    Other difference that I thought of was that the website that does not work runs on windows IIS 7.5, would that make any difference?

    Not sure if my problem is related but I have recently upgraded to WP 3.5 and Ninja forms 2.0.1.

    All my forms have disappeared from the site. They appear to be listed in the forms editor page but everything is blank – no Title, no fields, nothing. I’ve deactivated all other plugins but still nothing is showing up.

    I can’t create new forms either. And the Field settings tab isn’t working.

    Plugin Author James Laws

    @jameslaws

    Have you tried deactivating and reactivating Ninja Forms?

    Doh! No, I didn’t do that – seems to be working now.

    Thanks for the quick response

    Plugin Author James Laws

    @jameslaws

    You are very welcome. In some cases we have seen the upgrade get hung-up and this seems to fix the issue.

    Okay, sorry it took me a while to get down to testing this again. I don’t know if it would be better to open a new thread but I’ll put it here for now.

    I did some more testing and installed wordpress 3.5.1, then turned on wordpress network, then installed ninja forms 2.0.4

    I first did this on IIS 7.5 and then ninja forms does not work, I have the same issue as described above, I can create a new form but no fields, the field buttons are not draggable and nothing happens when I click on them.

    Then I did the same things on a local xampp server and it works. Do you have any idea why this would be?

    Plugin Author James Laws

    @jameslaws

    I have an Intranet that I maintain on an IIS7 server and it works fine there.

    The behavior you are describing is symptomatic of a javascript conflict of some sort. When you click or drag the field nothing happens which is a javascript event. Have you looked in your browsers console to see if there are any errors showing?

    I have tried in IE9 and in Chrome, no errors relating to javascript, IE has one relating to CSS.

    I just don’t know what would be the difference since I only use wordpress with standard twenty twelve theme in both places and ninja forms, I did not install anything else.

    sorry, there is an error in Chrome when I drag the buttons, not when I click on them.

    Chrome says:
    Uncaught TypeError: Cannot read property ‘tagName’ of undefined load-scripts.php:35
    e.widget._getParentOffset load-scripts.php:35
    (anonymous function) load-scripts.php:15
    e.widget._mouseStart load-scripts.php:35
    (anonymous function) load-scripts.php:15
    e.widget._mouseMove load-scripts.php:20
    (anonymous function) load-scripts.php:15
    _mouseMoveDelegate load-scripts.php:20
    v.event.dispatch load-scripts.php:2
    o.handle.u

    IE says:
    SCRIPT5007: Unable to get value of the property ‘tagName’: object is null or undefined
    load-scripts.php?c=1&load%5B%5D=jquery,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-datepicker,jquery-ui-draggable,jquery-&load%5B%5D=ui-droppable&ver=3.5.1, line 35 character 5132

    Plugin Author Kevin Stover

    @kstover

    We have had a user with what sounds like a similar issue on our wpninjas.com forums. I think that I have solved the problem and will be rolling the fix into Monday morning’s update. Please try out version 2.0.5 Monday and let me know if that takes care of the problem.

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘[Resolved] cannot add fields to a form’ is closed to new replies.
Skip to toolbar