Support » Plugin: wpDirAuth » Cannot add dir auth user – says they are already registered on this site.

  • Resolved dzarelli

    (@dzarelli)


    We cloned a blog to another page so that users could test updates and changes before publishing them to the live blog page. On the cloned page, when I try to add some users, I get the message “user is already registered on this site” even though they are not listed under users. Is this a known issue? Is there a fix or workaround? Thanks.

    • This topic was modified 4 months ago by  dzarelli.
    • This topic was modified 4 months ago by  dzarelli.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Paul Gilzow

    (@gilzow)

    Is this on a multisite installation?

    dzarelli

    (@dzarelli)

    Yes it is. We used MultiSite Clone Duplicator to copy the site. Thanks!

    Plugin Author Paul Gilzow

    (@gilzow)

    In a multisite, there’s only one collection of users and they are shared across all of the child sites. If the user has already been added to at least one other site, then for this new site, you’ll need to add them as an existing user. In the child site, you can do this under Users –> Add New, Add Existing User. Or you can add them from the Network Admin panel (assuming you have super admin account) from Sites –> Your Site –> Edit, Users tab, Add Existing User.

    dzarelli

    (@dzarelli)

    That did the trick. Looks like I was just performing the wrong action (“Add DirAuth user” as opposed to “add existing user”) Thank you for the help.

    Plugin Author Paul Gilzow

    (@gilzow)

    I can see how there might be confusion. I’ll add a note to the Add New Directory Authentication User that if it’s a multisite mentions adding existing users and then link over to the right area. That should be pretty easy to add.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.