Support » Fixing WordPress » Cannot add categories

  • Hi

    No matter what I try I cannot add new categories to my blog. I type them in and click ok but nothing new shows in the category list.

    Initially I installed wp and then wp-united to integrate a forum into my blog. Since then I have removed the forum and wp-united but feel this may have affected my settings along the line.

    Also when clicking ‘preview’ for a new post I’m writing it says there is no file by that name.

    So how can I do a clean install whilst retaining my new theme and posts/settings?


Viewing 11 replies - 1 through 11 (of 11 total)
  • Hi,

    I’m also getting the same problem and can’t seem to add a category – it just dos nothing. Any advice would be great.

    Thanks, Henny

    I have a new install and the problem is the same. Only the default category shows on site.
    Sorry I can’t help; not good enough!



    Automattic Happiness Engineer

    If you are talking about it not showing in the category widget when viewing the blog, a category will not show up in the category widget until it has been assigned to at least one post.

    I am also having problems with this. I installed the widget as suggested with no success on adding categories.

    Well, I logged out and then logged back in – worked like a charm.

    That used to happen to me – logging out and logging back in helped. I read somewhere that it might be caused by a Firefox extension – not sure which.

    In a different topic, I found the following fix that worked perfectly for me. 🙂

    disc0ver posted this fix:

    okay its a server problem after all:

    It was a mod_security issue
    add the following code in your .htaccess file
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off

    where is the .htaccess file??

    I cannot find this in my wordpress folder so I am stuck without categories!

    look in the root directory – make sure your FTP client is set to display hidden files (or ‘dot files’)

    i deleted the content on the .htaccess file and switched it to

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off

    IT WORKED PERFECT! now i can add categories to my project!

    wish you luck to anyone with this issue, i guess its 2.5.1 stuff

    Same problem though I used to be able to. My .htaccess reads,

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off

    Maybe taking out async-upload will fix it? Hmm.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Cannot add categories’ is closed to new replies.