Support » Fixing WordPress » Cannot add categories

  • I cannot add categories or change plugin content.

    When I try to add a category, on submit I get a page listing the front page content. Nothing happens to add category.

    I checked the mysql table in phpMyAdmin and the new categories are not there.

    It worked fine until tonight when I upgraded from 2.3.1 to 2.3.2

    Naturally I suspect the upgrade.

    Does anyone know how I can fix this or what’s wrong, and can you explain it without getting too technical?

    Thanks

    David

Viewing 15 replies - 1 through 15 (of 16 total)
  • I’ve got the same problem. I upgraded from 2.2.1 to 2.3.2 and all my categories are gone. I had three blogroll listings based on certain categories and they are unpopulated. Now they just say “no categories”.

    At first I thought it was a case of not getting all the new upgrade files installed, and re-uploaded all of them. The database was upgraded during the install at first.

    All the posts show up, and people are leaving comments. All is working normal except that my categories are not showing up.

    I know that blogrolls changed with 2.2 and I had to do some adjusting, but now I wonder if a bug is in 2.3. But judging by only a few posts regarding this problem, it doesn’t appear to be a “community-wide” problem or everyone would be screaming about it. But there are a couple posts today (1-5-08) that mention the same problem.

    Is there a problem with 2.3.2 that causes categories to be unread from the database, or are the categories wiped out of the database (I hope not…. there are over 1,000 posts in my database and I’d hate to have to re-categorize them).

    I should clarify that all posts are coming up as “uncategorized”.

    My old categories are in the database. I checked. I just can’t add new ones, or write to plugins.

    So the question is: since the categories are still in the database, how do they get reactivated?

    I look under Blogroll > Manage Blogroll and all my items have a blank category listing in the “category” column.

    If I read it write, 2.3 does some kind of conversion of categories to tags, but that shouldn’t eliminate the categories from being available yet.

    And we just tested to add a category and it doesn’t work. We can’t add new ones, either.

    Is there a fix for this, or does 2.3.3 need to come out ASAP and address this issue?

    I’m thinking of reinstalling 2.3.1 – are these security problems that warned me to upgrade that serious?

    I’m having the same kind of issues. After upgrading, all my posts are set to “uncategorized” with no link. My Blogroll->Categories page shows no categories nor can I add new (I never used that one before anyway) more importantly, my Manage -> Categories page is also empty. I can add a new category there and it’ll show up until I refresh then it disappears! In my Write -> Post page, the categories were not listed there at first, then they came back after a day with the parent/child showing and then it worked on my blog (public) for awhile as well. Today I lost all child categories in my Write -> Post list, it only shows parent and all public posts are again set to Uncategorized.
    I really only upgraded to the 2.3.2 and that’s all.
    I’m actually rather upset by this. Everything was working just fine without an upgrade but I saw there was some security threat and listened and now I’ve got this mess.
    *sigh*
    Thanks for any help!

    Edit- Also my Category drop-down menu has disappeared in my sidebar. It had disappeared when I first upgraded, then magically appeared again and now is gone yet again. Same sort of thing in other category areas! How strange!

    I downloaded my current database and compared it to a pre-2.3.2 upgrade copy from last week. The categories are still there in the database and the tables appear to be identical in regards to wp_categories.

    So it doesn’t look like a database problem. The solution we seem to need is for WP to accept those database paraments in the categories.

    And I wouldn’t have the first clue in knowing how that works.

    Fizzgig, I’m just like you, I wanted to upgrade from 2.2.2 while updating my wife’s blog design and saw “security upgrade” and thought, “well of course I should do that instead of 2.3.1 (which I’ve been using on newer projects).

    I hope we get a good answer because I’m at a loss what to do. My wife’s blog has 1000+ entries and she’d like her categories and blogrolls back.

    Oops, I meant to say, “The solution we seem to need is for WP to accept those database parameters for the category listings.”

    Fizzgig, I noticed the Manage > Categories situation, too. Since the “categories” column is empty, but still labelled as “categories”, I wondered why the categories aren’t showing up.

    And one more bit of info to help the situation: I did my wife’s redesign using the Default Theme in 2.3.2 and modified it to look like her old theme, which dated back to 1.5.2. So I used the current version’s Default.

    I’d almost think that I did something wrong in recoding the default theme, but since the categories don’t show up in the dashboard, I know it’s WP and not my theme.

    Yes I agree it’s definitely not a theme issue. I can’t imagine *what* the issue is but I’m working on it still.

    I wish you luck too! If you fix it please post here ok? Thanks.

    Solution found! Here’s a link to the solution I needed to use. And thanks to Michael the moderator who took the time to help me.

    http://wordpress.org/support/topic/150460?replies=15#post-673559

    The fix here is not what the OP asked about. He said he could not create a category… not that his categories are gone.

    My categories never disappeared… I simply cannot add new ones. I tried the solution posted here even though my categories were intact, and this did not fix the issue.

    When I try to create a new category I get the following error:

    “Something strange happened. Try refreshing the page.”

    If I try to create a post and add a new category in the side bar, I get the following error:

    “Fatal error: Cannot use object of type WP_Error as array in /home/.****/****/****.com/wp-includes/taxonomy.php on line 1014”

    All plugins are disabled and I still get this error.

    Any suggestions?

    I resolved my issue by doing a complete reinstall of the latest version of WordPress.

    I’m having similar issues on a fresh install of 2.3.2. Can’t add catagories, either on the write post or manage/catagories. When I try and click add another page is displayed within the area where you enter the catagory name and info. Being a clean install and not an upgrade suggests this is a major bug. At the moment I am considering installing 2.3.1 untill this is figured out. Unless someone has an answer.

    My issue has been solved. After installing 3 versions of wordpress and still having the same problem contacted the host. Turned out to be a mod_security restriction set by the hosting company. They removed the restriction and all is grand.

    The rule that caused the problem was:
    The rule “!(^$|^application/x-www-form-urlencoded$|^multipart/form-data)” is added under mod_security to prevent server from web attacks such as iframe injection or XSS attack(HTML/Javascript injection)

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Cannot add categories’ is closed to new replies.