Support » Plugin: Google Maps made Simple » Cannot Add a marker

Viewing 7 replies - 1 through 7 (of 7 total)
  • I have the same problem. It seems that all the free map software is making a conspiracy not to give markers out for free. I’ve tried at least 5 plugins.

    @vjakopin: It is impolite to interrupt another poster’s ongoing thread with a question of your own. It causes significant problems for the forum’s volunteers and prevents us from being able to track issues by topic. Please post your own topic.

    Sorry guys.

    Ordinarily, I avoid editing core code as much as possible. However, the plugin itself was broken due to the WordPress Core changing how it utilizes Thickbox and the tb_show() function.

    If you want to get your hands dirty, open up your Plugin Editor (Plugins->Editor) and select Google Maps Made Simple. Click on the wpgmappity-iframe.js file, and search for a function called “wpgmappity_set_add_marker_event”.

    This function binds various click handlers to the Add Marker link and other elements.

    Right below the function, you will see the following lines:

    jQuery("#wpgamppity_add_marker_go").click(function() {
        tb_show('Add a Marker',
            "#TB_inline?height=450&width=475&inlineId=wpgmappity_add_marker_dialog",
            null);
        return false;
    });

    Change it to the following:

    jQuery("#wpgamppity_add_marker_go").click(function(){
        jQuery("#wpgmappity_add_marker_dialog").show();
        return false;
    });

    It’s not a great fix, but it will do for now until the original developer updates the plugin to reflect the new Thickbox changes.

    maiorano84 thank you! I had the same issue and your code worked fine!

    Now, is there a way to edit the marker created? Because when I hint “Configure”, the same shadow appears and nothing happens.

    gabisaraceni: Anytime, homie. Yes, configuring the marker is also possible.

    Plugins->Editor->wpgmappity-iframe-markers.js
    Find “wpgmappity_configure_marker_callback”

    Change this line:

    tb_show('Marker Configuration',"#TB_inline?height=220&width=475&inlineId=wgmappity_marker_configure_dialog", null);

    To this:

    jQuery("#wgmappity_marker_configure_dialog").show();

    Make sure to save the map itself for your changes to take effect.

    Once again, the solution to the problem isn’t pretty, but it’s quick and it does the job. I’ve submitted a pull request on GitHub for the original developer, so hopefully he can provide a more user-friendly fix.

    Best of luck to you.

    maiorano84 thanks again! It worked well!

    Yes, I realise that is not the best solution, but your code is something we can count in until the developers release the bug fix. Hope they answer to your request. 🙂

    Regards.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Cannot Add a marker’ is closed to new replies.