Support » Plugins and Hacks » [Resolved] cannot activate…displays the following error

[Resolved] cannot activate…displays the following error

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Evan Herman


    What does that file, scripts.php look like for you? There should be no errors, especially upon activavtion

    the first few lines in script.php are as:

    function wordpress_svg_icon_plugin_load_style() {
    	wp_register_style( 'svg-icon-set1-style',  plugin_dir_url(__FILE__).'css/wordpress-svg-icon-plugin-style.css');	
    	wp_enqueue_style( 'svg-icon-set1-style' );
    	wp_register_style( 'svg-icon-set1-expansion-style',  plugin_dir_url(__FILE__).'css/wordpress-svg-icon-plugin-expansion-style.css');	
    	wp_enqueue_style( 'svg-icon-set1-expansion-style' );
    		$dest = wp_upload_dir();
    		$dest_path = $dest['path'];
    		$customFontPackPath = $dest_path.'/wp-svg-icons/custom-pack/';
    		$current_year = date('Y');
    		$current_month = date('m');
    		$date_concatenation = $current_year.'/'.$current_month.'/';
    		$customFontPackPath = str_replace($date_concatenation,'',$customFontPackPath);
    		$customPackStyles = '/style.css';
    			// Check if there is a custom pack style file
    			// if there is enqueue it
    			if ( file_exists($customFontPackPath.$customPackStyles)) {


    Plugin Author Evan Herman


    Please don’t yell. That won’t accomplish anything any faster.

    If you want to grant me access to FTP, I can take a look. Other than that everything looks fine in that file.

    If you’d like me to take a look you can email me at Evan.m.herman@gmail.com

    Plugin Author Evan Herman


    I would also double check there are no leading empty spaces at the top of the document, in any of the files. I’m not sure why your seeing that error.

    Try removing the comment,


    but again that shouldn’t be causing any issues.

    I’m not yelling…in fact I’m impressed and grateful for your replies….how do I grant access to ftp? should I send you my password???

    I removed the code you mentioned. It doesnt help.

    Plugin Author Evan Herman


    You’ll need to get in contact with your host provider to get the FTP details. It doesn’t seem to make sense that your receiving an error on activation. Maybe it’s conflicting with another plugin you have installed?

    ok it’s working now. had to delete all the other plugins first though…perhaps it was conflicting with some plugin I had previously installed…thank you so much for your response.

    but how do I add put these icons slongside the menu links as in makeuseof.com ? and how do I get a sticky header like that of makeuseof.com’s? sorry for asking it here but I have never gotten any help/reply from the wordpress suppost forum…It’s disappointed me so much so that I have started learning css and php by myself…never thought would need to learn them. I just know some html. suggest me a theme that is easy to customize and looks like makeuseof.com (especially the sticky header) and is free. I’d have loved to pay for a premium theme but I dont have a credit card and they dont take cash.

    Plugin Author Evan Herman


    If you want to add the icons to the menu, you’ll need to look through the CSS file included with the plugin, and then add some more CSS styles to the navigational items.

    I have set up a demonstration of doing so on my site here. Scroll down to adding icons to the navigation.

    That should point you in the right direction.


Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] cannot activate…displays the following error’ is closed to new replies.