Support » Plugin: Markup by Attribute for WooCommerce » Cannot Activate Plugin

  • Resolved patchwebdesign

    (@patchwebdesign)


    When I try to activate, I get this error

    Fatal error: Uncaught Error: Class ‘MT2MBA_UTILITY_GENERAL’ not found in /wp-content/plugins/markup-by-attribute-for-woocommerce/markup-by-attribute-for-woocommerce.php:95 Stack trace: #0 wp-admin/includes/plugin.php(2050): include() #1 /wp-admin/plugins.php(175): plugin_sandbox_scrape(‘markup-by-attri…’) #2 {main} thrown in /wp-content/plugins/markup-by-attribute-for-woocommerce/markup-by-attribute-for-woocommerce.php on line 95

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Mark Tomlinson

    (@marktomlinson)

    Sounds like it didn’t download correctly or the autoloader isn’t working in your environment.

    Since I can’t seem to reproduce the problem, can you help me the following?

    1. How did you install? Manually or through the WordPress [Add New] dialog?
    2. Can you look at WooCommerce > Status and tell me what your PHP Version is? It will be under Server Environment heading.
    3. This one’s a little tougher. Can you go to Plugins > Plugin Editor, and select Markup by Attribute for WooCommerce where it says ‘Select plugin to edit’? Then, on the right, select ‘src >’, then ‘utility >’. There should be three modules listed, like this screenshot. Is that what you see?

    1.Installed through WordPress
    2.PHP version is 7.0.33 (which is confusing as in cpanel it is set to 7.2???)
    3.Yes

    I also ahve the following Woocommerce plugins if it may be a compatibility issue. I will go through the list one by one when I have time.

    WooCommerce Blocks
    WooCommerce Cart
    WOOF – WooCommerce Products Filter
    WooCommerce Amazon S3 Storage
    Advanced WOO Search

    Plugin Author Mark Tomlinson

    (@marktomlinson)

    This does not sound like a compatibility issue. The error is telling us that it can’t find the class MT2MBA_UTILITY_GENERAL, which you should have seen on line 12 of markup-by-attribute-for-woocommerce/src/utility/general.php.

    So, that tells me that it can’t find general.php. To confirm, I was able to reproduce the error message almost exactly by deleting general.php.
    Fatal error: Uncaught Error: Class 'MT2MBA_UTILITY_GENERAL' not found in /var/www/html/wpdev/wp-content/plugins/markup-by-attribute-for-woocommerce/markup-by-attribute-for-woocommerce.php:95 Stack trace: #0 /var/www/html/wpdev/wp-admin/includes/plugin.php(2050): include() #1 /var/www/html/wpdev/wp-admin/plugins.php(175): plugin_sandbox_scrape('markup-by-attri...') #2 {main} thrown in /var/www/html/wpdev/wp-content/plugins/markup-by-attribute-for-woocommerce/markup-by-attribute-for-woocommerce.php on line 95

    This is a headscratcher. Sorry for asking if you’ve already done this, but can you delete the plugin and reinstall it?

    Plugin Author Mark Tomlinson

    (@marktomlinson)

    Have not heard back in a month. Assuming the issue was resolved by patchwebdesign.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Cannot Activate Plugin’ is closed to new replies.