WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Cannot activate plugin

[Resolved] Cannot activate plugin

  • Hey,

    after upgrading WordPress to 3.5.0 and then 3.5.0 I cannot use this plugin anymore. When I try to activate it the following message from WP is showing up:

    Plugin could not be activated because it triggered a fatal error.
    Fatal error: Class ‘OGraphr_Admin_Core’ not found in /path/to/wordpress/wp-content/plugins/meta-ographr/meta-ographr_admin.php on line 20

    Before the named version the plugin was usable.

    Cheers!

    http://wordpress.org/extend/plugins/meta-ographr/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author idleberg

    @yathosho

    i’m assuming you’re using the latest plugin version and do not run wordpress in debug mode? php version? logged in as admin?

    Your guess is correct, using the latest version of OGraphr and WP is not running in debug mode. PHP version is 5.3.18 and I am logged in with admin rights.

    Plugin Author idleberg

    @yathosho

    try a manual install of the plugin and see what happens. i found several class errors on the wordpress support pages and that fixed it most of the time.

    Fatal error in the output generally indicates either your theme doesn’t like your version of WordPress, you have a plugin that doesn’t like your version of WordPress, or you have an incomplete install/upgrade.

    i tried reproducing the problem on a clean wordpress installation, but to no success. also, i got it running on several other sites that i recently upgraded to the latest wordpress.

    hope we can nail this down!

    I always do a manual install so this makes no difference. I also set up a new database and instance of WP and tried only this plugin, but no luck. Even in debug mode are no other messages. So I assume that there is a problem with the latest PHP update, hardened settings or something. I am irritaded, because it worked before, no sufficient changes were made and everything else is working.

    Plugin Author idleberg

    @yathosho

    i can’t install php 5.3.18 on my server, but the plugin runs fine with php 5.3.19. i do get a warning (see below) on the plugin page after activation, but no problems in functionality.

    The plugin generated 260 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

    i’m pretty clueless, but i’ll investigate a little.

    edit: found the problem for the warning, but it’s probably not related to your problem (you can give it a try though: http://db.tt/8iZ4J9jE)

    Okay, I think I found the bad guy. While tinkering around with this XCache chrashed with a segfault and after this I could activate the plugin with no problem. After restarting the PHP process with loaded XCache I got the error message as above again. So I deactivated XCache and everything is working fine.

    Sigh.

    Plugin Author idleberg

    @yathosho

    i found this, but after applying the fix i got the very same error – and i didn’t get it before :/

    For me the fix does not work either. I leave XCache deactivated for the domain using ographr. Maybe one of the next stable versions (on my distro) of PHP/XCache will get me rid of this.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Cannot activate plugin’ is closed to new replies.