• Resolved aqdennis

    (@aqdennis)


    In order to use SendCloud for sending packages I must enable HPOS. However, the option to do so is disabled. I read that one should activate the compatibility mode, which I did, but without effect. I’ve waited 24 hours (though I only have a few hundred orders to synch) but the option to enable HPOS is still disabled. Running the sync task manually says it succeeded….
    I have no pending orders….actually, the webshop has not been used for the last 6 months due to moving the company.
    No idea what is the problem here.
    WordPress version 6.5.2, WooCommerce version 8.8.3.
    I’m running Woocommerce Subscriptions and WPML, maybe that has something to do with it?

    Thanks,
    Dennis

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Shameem (woo-hc)

    (@shameemreza)

    Hi @aqdennis

    Do you see any extension incompatible with HPOS under WooCommerce > Settings > Advanced > Features? You can also visit https://example.com/wp-admin/plugins.php?plugin_status=incompatible_with_feature&feature_id=custom_order_tables to review the list of incompatible extensions (replace example.com with your site domain).

    Also, is there any pending actions under WooCommerce > Status > Scheduled Actions?

    However, please note that the synchronization adds a small overhead over both the old CPT and the new HPOS tables compared to the situation when they’d be used by themselves; it’s a necessary transition phase while some plugins still expect records in the posts and postmeta tables. We expect this to be temporary mitigation to prevent stores from breaking. This also enables stores to roll back easily, as the orders would still be stored as they were previously. 

    More info can be found here: https://developer.woocommerce.com/2022/09/29/high-performance-order-storage-backward-compatibility-and-synchronization

    I hope this provides some clarity. Looking forward to hearing from you soon.

    Thread Starter aqdennis

    (@aqdennis)

    I have no incompatible plugins. There is a synchronization action that runs every hour and says to be successful.

    However, I dont know how compatibility is checked? I have written some code snippets that may depend on the old database structure, but i dont know whether woocommerce would actually detect that?

    • This reply was modified 1 month, 1 week ago by aqdennis.
    Plugin Support Shameem (woo-hc)

    (@shameemreza)

    Hi @aqdennis

    WooCommerce checks for compatibility by looking for certain hooks and filters used by extensions. If your custom code snippets use these hooks and filters, they may be flagged as incompatible.

    If you have written custom code snippets that depend on the old database structure, it’s possible that these could be causing the issue even if they aren’t being detected as incompatible. It’s also possible that the issue might be related to a conflict with WPML plugins.

    The best way to determine this is to:

    • Temporarily switch your theme to Storefront or Twenty Twenty-Four
    • Disable all plugins except for WooCommerce
    • Repeat the action that is causing the problem

    If you do not see the same problem after completing the conflict test, then you know the problem was with the plugins and/or theme you deactivated. You can find a more detailed explanation on how to do a conflict test here.

    I hope that helps! Let me know once you have done a conflict test!

    Thread Starter aqdennis

    (@aqdennis)

    Hi,

    I did the conflict test and to my surprise …. it’s a Woocommerce plugin causing the conflict: “WooCommerce Legacy REST API” plugin. I know see in the description of the plugin that that is indeed a known problem.

    The funny situation is that SendCloud requires HPOS as well as the Legacy REST API, which seems to be an impossible combination. But that is of course not your problem.

    Thank you for your help,

    Dennis

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.