Support » Plugin: OWM Weather » Cannot Activate

  • Resolved cambofrizz

    (@cambofrizz)


    Unfortunately, there seems to be something terribly wrong with this plugin. While trying to activate it, the admin plugin page freezes and I get the message “This site can’t be reached”. When reloading the plug-in page, the plug-in is not activated.

    I manually activated the plugin, and for a short time it shows the activated status, but there’s no ‘Weather’ menu item and after a few seconds the same as above happens.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author uwejacobs

    (@uwejacobs)

    Hi cambofrizz,

    The plugin is running without any issues on several life pages. Do you have a way to turn on the WordPress Debug mode or install a debug plugin?

    Thread Starter cambofrizz

    (@cambofrizz)

    Just FYI: I’m trying to install this on a localserver development website. The website is a clean WP install with no other plugins activated. WP_DEBUG shows nothing, no log file is created.

    As the error message is a connection issue, I suspect the problem may have to do with my local SSL certificate, which of course is a ‘self-signed’ one. I’m using Laragon as the local server environment. I never had a problem activating plugins on this local SSL certificate, but I know this sometimes gives problems.

    I tried to remove the SSL and just use http instead of https, but that gave the same result.

    And you are right: on a live server I had no problem installing the plugin, so it definitely has something to do with localserver. Which, by the way, is important to me for developing websites.

    • This reply was modified 8 months, 1 week ago by cambofrizz.
    Thread Starter cambofrizz

    (@cambofrizz)

    I just installed the original plugin (WP Cloudy) and that gave no error on activation or in use. But that one of course is very old and also doesn’t use ‘onecall’ as far as I can see.

    Plugin Author uwejacobs

    (@uwejacobs)

    The switch to ‘onecall’ was the main motivation to pick up the otherwise excellent WP Cloudy and start a new plugin.
    When I have a minute, I will setup a new virtual box with Laragon and try it out myself.

    Thread Starter cambofrizz

    (@cambofrizz)

    I just did a fresh install of XAMPP and WordPress: unfortunately got the same result when trying to activate the plug-in. So, it seems not related to Laragon but to localhost in general.

    Plugin Author uwejacobs

    (@uwejacobs)

    I installed Laragon and was able to reproduce the activation issue. It boiled down to the ‘echo()’ display for the weather page options. This has grown quite a bit compared to WP Cloudy and Laragon just chocked on it without any error log. After changing the echo() to ob_start() / ob_get_clean(), the activation finishes in Laragon. Please install the updated version 5.0.2 and let me know in case you have any further issues.

    Thread Starter cambofrizz

    (@cambofrizz)

    Thank you very much, that worked!
    You have made a fantastic plug-in, I really like it.

    A few remarks:
    It seems the icon set-up needs attention, as the current weather icons always load Climacons, regardless of the Icon Pack settings. Also, with some other pack settings (e.g. Weather Icons), the temperature units are not displayed and in the forecast the condition icons are missing, too. Not sure if it is related, but why is there no ‘default’ choice in the individual weather Icons Pack setting?

    Also, the hourly forecast in the table setting ignores the setting in ‘Number of hours’ and displays the standard 48 hours.

    The above is just to fine tune, because again, it’s an excellent plug-in!

    Plugin Author uwejacobs

    (@uwejacobs)

    Thanks for your kind words. Please update to version 5.0.3:

    • The weather page setup lost some settings when editing the options. This has been fixed.
    • The WeatherIcons iconpack is working again.
    • The animated main icon will be replaced with the one from the selected iconpack when you check the layout option “Disable animations for main icon? “. Animations default to Climacons SVGs.
    • The table and chart templates will now honor the selected number of hours and days to forecast.
    Thread Starter cambofrizz

    (@cambofrizz)

    Thanks very much for your fast reply and fixes. Working fine now.

    There’s just one little glitch: while sunrise and sunset in the ‘Today’ panel are in local time, moonrise and moonset are not: the time zone is added twice to the UTC time.
    It’s because in owmweather.php on lines 2049 and 2050 the time zone is added. However, it takes the time from the daily moonrise and moonset data where that already has happened.

    Thread Starter cambofrizz

    (@cambofrizz)

    Oh, one more thing: the input for latitude (owmweather.php line 502) is forcing a value of 90, should be min=”-90″.

    • This reply was modified 8 months ago by cambofrizz.
    Plugin Author uwejacobs

    (@uwejacobs)

    Thanks for your detailed bug reports! The fixes will be in the next patch.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Cannot Activate’ is closed to new replies.