The update now requires PHP 5.3 as PHP 5.4.11 is now the latest stable version according to http://php.net. I apologize that many of you are having errors with either just having a lower PHP version or just having other plugins / theme code that is throwing errors within an upgraded PHP 5.3 install. PHP 5.3 was released in June 2009 so this is something that has been throughly tested and is ready for production use by most standards.
If you have these errors or if you cannot upgrade to 5.3 I highly suggest you download an archived version, the latest that supports 5.2 is version 1.0. I will not be supporting 5.2 in any manner going forward with my plugins. I will be amending the README and other documents for the plugin to reflect the requirement of PHP 5.3.
With that said, it seems like the majority of the issues within this thread have been solved with the upgrade to PHP 5.3.
If anyone has any further issues other than the PHP 5.3 issue, please open a new thread with a description of your issue.
@flamenco, any issues that occur from a PHP 5.3 upgrade would be related to bad code within either plugins or themes. So with that said, I have this plugin working with no errors within a PHP 5.3 environment with quality, error free, code behind my theme and plugins being run.