Support » Plugin: Image Watermark » cannot activate 1.6.3

  • Hi, I was investigating a potential conflict with the EWWW Image Optimizer (I’m the author), and installed version 1.6.3 just now.
    When I went to activate, it complained that the plugin did not have a valid header.
    Looking at what it tried to activate showed it was looking at image-watermark/1.6.3/image-watermark.php, which seemed very weird.
    So I took a quick look at the plugin files, and it appears you accidentally copied the plugin inside of itself, which is confusing WordPress a bit.

    Removing the 1.6.3 sub-folder appears to fix it, just thought you should know!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Also, it would be very useful to have the $data (attachment metadata) passed along with the ‘iw_after_apply_watermark’ filter. Or even better, pass the filename along, or both, so other plugins don’t have to re-query things that are already known to the IW plugin.

    Plugin Author dFactory

    (@dfactory)

    There must have been an issue with the plugin update.
    We don’t have it like that locally, but it’s indeed doubled in the repo.

    Working on a fix.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘cannot activate 1.6.3’ is closed to new replies.