Support » Fixing WordPress » Cannot access wp-admin after upgrade

  • I just tried it automatically upgrade to 2.8.4. I can get to the site, however, when i try to go into the dashboard, I get the following error:

    Fatal error: Call to undefined function _x() in /mnt/xxxxx/xxxx/xxxxxxxxxx/xxxxxx.com/wp-admin/menu.php on line 35

    Thank you for your assistance

Viewing 6 replies - 1 through 6 (of 6 total)
  • First thing I’d try would be to FTP the wp-admin and wp-includes folders manually from the zip file. Download the zip here:
    http://wordpress.org/download/

    Probably just a corrupt file, but post back if it doesn’t work.

    I gave it a shot and now the site doesn’t display and I get this error:

    Fatal error: Class ‘Translations’ not found in /mnt/xxxxx/xxxx/xxxxxxxxxx/xxxxxxxxxxx.com/wp-includes/l10n.php on line 407

    Thanks for your help

    Okie doke. FTP the files in the root directory too then. Don’t touch wp-config.php though. 🙂

    Sweet…that worked! Thanks.

    Follow up question….will I need to re-install or do any customizations due to overwriting those files?

    THANKS!!!

    No worries.

    You shouldn’t need to. All you’ve done there is manually do what the automatic upgrade script does. Sounds like it just didn’t install fully via the automatic script, so the new version was trying to call some files that weren’t uploaded yet, hence the errors.

    ok great. I appreciate your time

    thank you!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Cannot access wp-admin after upgrade’ is closed to new replies.