Cannot access /Wp-Admin (9 posts)

  1. Benji
    Posted 4 years ago #

    Hi All,

    Apologies as this question seems to be posted countless times. However I have gone through just about every conversation and tried every piece of advice mentioned and I still haven't solved the problem.

    I suddenly don't seem to be able to access my /wp-admin page no matter which method I try to reach it and I think it may be since I updated to 3.2.1.

    One of the things I have tried since is to edit the wp-config folder code to show define('WP_DEBUG', true); and the following message was displayed:

    Notice: Undefined index: action in /home/sites/experiencedaygiftideas.com/public_html/wp-content/themes/shopperpress/functions/custom-options.php on line 323

    Fatal error: Cannot redeclare wp_write_stats() (previously declared in /home/sites/experiencedaygiftideas.com/public_html/wp-load.php:61) in /home/sites/experiencedaygiftideas.com/public_html/wp-load.php on line 61

    I believe line 323 in custom-options says:

    global $pagenow; 
    if ( $pagenow == "wp-login.php"  && $_GET['action'] != 'logout' && !isset($_GET['key']) ) {
    	add_action('init', 'cp_login_init', 98);

    [Code moderated: please ensure that your code is enclosed in backticks (`) or use the code button.]

    and line 61 in wp-load says:

    [Code moderated as per the Forum Rules. Please use the pastebin]

    Can somebody please tell me if the above looks wrong? Unfortunately I'm not technical enough to understand.


  2. keesiemeijer
    Posted 4 years ago #

    Can you paste and submit the code of wp-load (line 61) into a pastebin.com and post the link to it here? see the Forum Rules for posting code and using the pastebin.

    - switching to the default theme by renaming your current theme's folder in wp-content/themes using FTP or whatever file management application your host provides.

    - resetting the plugins folder by using FTP or whatever file management application your host provides. Sometimes, an apparently inactive plugin can still cause problems.

  3. Benji
    Posted 4 years ago #

    Hi Keesiemeijer,

    Really sorry about that! I was too eager to get my problem up I didn't realise how many lines of code there were when entered into the wp text field, in my text editor it's one long line.

    Please have a look at the link http://pastebin.com/TjtAHzfX.

    I have tried my naming the theme and plugin folders as well as removing lines of white space within certain files and still cannot access the screen.

    In Opera or Firefox I get the following message in the browser window:

    In IE I Get a 500 internal server error?


  4. keesiemeijer
    Posted 4 years ago #

    If that code in the pastebin is from public_html/wp-load.php I think your site has been hacked. try the solutions provided here:


    You are not on the default theme but on the shopperpress theme. Did the renaming of that themefolder not work?

  5. Benji
    Posted 4 years ago #

    Thanks Keesiemeijer. I will read through the forums mentioned above.

    I have just renamed the top level shopperpress folder (I was renaming the 'theme' folder before) and now I can access my dashboard. Once in if I rename the shopperpress folder back and refresh my dashboard I can acess my shopperpress settings.

    This is a long winded method however at least I can work on my site until I find a long term fix.

  6. keesiemeijer
    Posted 4 years ago #

    Read the above links provided because your site has been hacked. I've decripted the code in your wp-load.php, and you can see it here: http://pastebin.com/jRVGJu7r

    This probably does't mean much to you (and me for that matter), But maybe someone on the forums can look at it and tell us what kind of hack this is. It looks like they download code from this domain: 1433norangegrove[dot]com

  7. Benji
    Posted 4 years ago #

    Will do! Thanks again I really appreciate your help!

  8. harvest316
    Posted 4 years ago #

    Bang on. Same problem here. I'm guessing a WP reinstall might have fixed it, but easiest fix was to copy wp-load.php from another blog. But with a non-standard admin userid & long random password, I fail to see how they got in. I'm wondering if it's internal inside my hostmonster shared hosting, since I recently started using memcached which runs in a shared space and mentions firewall issues.

  9. harvest316
    Posted 4 years ago #

    Consider locking down access rights on wp-load.php a little tighter?

Topic Closed

This topic has been closed to new replies.

About this Topic