WordPress.org

Forums

iThemes Security (formerly Better WP Security)
Cannot access site at all - redirects to web host's 404 page (5 posts)

  1. xondra
    Member
    Posted 1 year ago #

    I just updated Better WP Security to Ithemes security. Everything seemed to go smoothly and I even activated the option to stop others from executing scripts via url, but as soon as I logged off I was unable to return to my site, and I even get redirected to my web host's 404 page. Since this is a free service I'm not sure my support ticket will be answered and I have no idea how to recover my site. Please help.

    Greetings,

    https://wordpress.org/plugins/better-wp-security/

  2. xondra
    Member
    Posted 1 year ago #

    I also changed my nickname and asked wordpress to use it for public display. I've no idea whether this has anything to do with anything, but I'm offering some info on my site's configuration so someone might help:

    I had changed my wp_content folder's name prior to the update
    I had hid my htaccess file prior to the update
    I had changed my database prefix prior to the update
    I clicked "save settings" several times after reviewing them and thinking them exactly the same as before"

    That seems to be the most critical aspects of my Better WP Security settings.

    Before upgrading I had to upgrade my theme and a couple of plugins. The last plugin I updated was WordPress Seo by Yoast, the only plugin I updated after upgrading to Ithemes S.

    I also added a couple of lines to htaccess to increase execution line, but erasing them doesn't fix the problem, so I think it's unlikely they are the cause of it.

  3. xondra
    Member
    Posted 1 year ago #

    It's definitely something to do with some rewriting of htaccess. I have a way older copy of it, uploaded it and my site just came back, but I'm hoping for developers to fix this issue as soon as possible.

  4. xondra
    Member
    Posted 1 year ago #

    The logs section of the plugin's dashboard recorded the 404 errors. When I click "details", this is everything I get:

    Array
    (
    [query_string] =>
    )

    Does anyone know what that means?

  5. cyanidsyd
    Member
    Posted 1 year ago #

    can't access my sites admin at all after update, Have had to remove plugin just to gain access.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.