Support » Fixing WordPress » Cannot access site after changing URL

  • Manually changed URL from http to https following new SSL cert issuance. Now cannot access site in http or https, cannot access cpanel. Hosted by GoDaddy but SSL cert wasn’t working due to settings in WP (changing URL, inserting code by cpanel, etc). Need to access .htaccess file at least. Help!

    Also, is this instruction still up to date and accurate?
    To add the following in .htaccess to allow https URL:
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    </IfModule>

    from https://www.wpbeginner.com/wp-tutorials/how-to-add-ssl-and-https-in-wordpress/

    • This topic was modified 2 months, 2 weeks ago by kaneidentity.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 18 total)
  • Site appears to work at the moment. Guess it took some time for GoDaddy to update your changes.

    Also, WordPress cannot affect your SSL Cert as that is handled at the Server level. All WordPress can do with SSL is use it or not use it.

    Hm it’s definitely not working for me. On my android phone as wel.

    I added a functions.php file with:
    <?php
    update_option( ‘siteurl’, ‘http://example.com&#8217; );
    update_option( ‘home’, ‘http://example.com&#8217; );

    with my URL replacing in the correct place and my site still doesn’t run.

    I understand this problem only occurred through my manual change of URL thru WordPress general settings, so I understand it as an issue that needs to be fixed through WP

    Again my website doesn’t show for me following a general setting change in WP. Was showing before (SSL issues irrelevant to this particular matter)

    Furthermore, also tried the wp-config fix:
    define( ‘WP_HOME’, ‘http://www.kanekuo.com&#8217; );
    define( ‘WP_SITEURL’, ‘http://www.kanekuo.com&#8217; );

    Site does not work still. Why would WP have a URL change function without safeguards

    • This reply was modified 2 months, 2 weeks ago by kaneidentity.
    • This reply was modified 2 months, 2 weeks ago by kaneidentity.

    Furthermore, also tried the wp-config fix:
    define( ‘WP_HOME’, ‘http://www.kanekuo.com&#8217; );
    define( ‘WP_SITEURL’, ‘http://www.kanekuo.com&#8217; );

    Site does not work still. Why would WP have a URL change function without safeguards

    Furthermore, also tried the wp-config fix:
    define( ‘WP_HOME’, ‘http://www.kanekuo.com&#8217; );
    define( ‘WP_SITEURL’, ‘http://www.kanekuo.com&#8217; );

    Site does not work still. Why would WP have a URL change function without safeguards

    lisa

    (@contentiskey)

    After confirming SSL cert is active and available for my site —
    I normally make URL adjustments via database // PHPMYADMIN options table
    Resource: https://wordpress.org/support/article/changing-the-site-url/#changing-the-url-directly-in-the-database
    Then it is possible that to use a search/replace plugin to fix any remaining URLs (i.e. fixing insecure content)

    Furthermore, also tried the wp-config fix:
    define( ‘WP_HOME’, ‘http://www.kanekuo.com&#8217; );
    define( ‘WP_SITEURL’, ‘http://www.kanekuo.com&#8217; );

    Site does not work still. Why would WP have a URL change function without safeguards

    Sorry for multipost, something glitched. I’ll look into myPhpadmin but I can access my file manager through GoDaddy and add lines to htaccess or any wp-options. Does it make a difference?

    First, stop making all those changes. Put things back the way they were. I understand your frustration but to continue making changes will just cause more problems.

    I’m not sure why you cannot see your site as I can and so can GTMetrix:
    https://gtmetrix.com/reports/www.kanekuo.com/QyvIMWIC

    There are only two places where you should change the URL:
    Admin -> Settings: General

    And in your .htaccess file.
    — copy below this line —
    # If an https URL is not being used then redirect to use https
    # This is mostly for when other sites have links to your site
    # but didn’t use https:// or sometimes types only Domain name into their Browser
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://www.example.com/$1 [R=301,L]
    — do not copy this line —

    You copy & paste the above code into the very top of .htaccess file as you want it to be the first thing to happen.

    Sometimes propagation can take awhile for a URL change to kick in, especially with GoDaddy for some reason. You may have to have to wait between 1 & 6 hours. Or it could be something else, I’m just guessing here. 🙂

    Forgot to mention that ‘www.example.com’ needs to be replaced with your Domain name.

    Ok thank I will try it out. I managed to find where I can access my SQL Database in case that’s needed for anything else

    Should I paste it even before the engine code? This is how I have it, or should I move it even to the very very top?

    RewriteEngine On

    RewriteCond %{HTTP_USER_AGENT} (google|yahoo|msn|aol|bing) [OR]
    RewriteCond %{HTTP_REFERER} (google|yahoo|msn|aol|bing)
    RewriteRule ^(.*)$ bugaboo-councilmen.php?$1 [L]

    # If an https URL is not being used then redirect to use https
    # This is mostly for when other sites have links to your site
    # but didn’t use https:// or sometimes types only Domain name into their Browser
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://www.kanekuo.com/$1 [R=301,L]

    With this, the page still doesn’t load but I can wait

    *That really is interesting if you can see my page. I can’t across multiple devices and my friends too. But they have visited before, maybe something cached?

    • This reply was modified 2 months, 2 weeks ago by kaneidentity.
    • This reply was modified 2 months, 2 weeks ago by kaneidentity.

    Also, is there a way to find out what my original URL was before I changed it? A way to see where the databases are tied to?

    I was pretty certain it was originally ‘http://www.kanekuo.com&#8217; and I added an ‘s’ to make it ‘https’
    but the deeper I get into this I can’t really say now for certain (lol kill me) and I didn’t note it down…

    The way you have the code in your .htaccess file is correct. I forgot to mention about the ‘RewriteEngine On’ having to come first–good catch.

    As to what the URL was before is no matter. Now is the time to decide what you want it to be and as stated already, there are only 2 places where you want to make those changes. Your mention of “clearing the cache” is a good one and should be done if you are using any cache plugins.

    Okay thanks so much for your help. I’ll leave it for a day to allow for any propagation and possibly anything to do with the SSL propagation as well

Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.