WordPress.org

Forums

WP Tiles
[resolved] Cannot access self (4 posts)

  1. Edwin Brinkhuis
    Member
    Posted 1 year ago #

    Its a problem some people have too...
    I cannot activate the latest 1.0 beta after upload from the .zip.

    This is the error I get:

    Fatal error: Cannot access self:: when no class scope is active in xxx/httpdocs/wp-content/plugins/wp-tiles/src/WPTiles/Admin/Admin.php on line 126

    No hurry!

    https://wordpress.org/plugins/wp-tiles/

  2. Mike Martel
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Edwin!

    Thanks for your feedback. Silly oversight this one. I just uploaded this in the trunk version here.

    I didn't get a chance yet to go through the code and check if I did this more often, but this one is now fixed.

    Thanks for testing the new version and do let me know if you run into anything else!

    Cheers,
    Mike

  3. Edwin Brinkhuis
    Member
    Posted 1 year ago #

    Thanks Mike!

    I got it working on one testsite.
    Another site says during activation:

    Fatal error: Class 'WPTiles\WPTiles\WPTiles' not found in xxx/httpdocs/wp-content/plugins/wp-tiles/src/WPTiles/Legacy.php on line 136

    I had the production version running there but deleted it before installing the trunk version

    Thanks, Edwin

  4. Mike Martel
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Edwin, happy you got it to work.

    The other error is from the class that handles backward compatibility - exactly the bit that needs testing. Just committed a fix for that (in the trunk version). Let me know if you run into anything else!

    Mike

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Tiles
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic