Support » Plugin: Google Pagespeed Insights » Cannot access scheduling or advanced options

  • I just installed your plugin. When I accessed the options tab the first section to add the API is expanded and I could use it fine. But, when I tried to click the scheduling and advanced options sections nothing happens. I tried in both Firefox and Chrome browsers.

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’m also seeing this issue. I haven’t been able to open the scheduling or advanced options at all.

    • This reply was modified 4 months, 3 weeks ago by jbusch.
    Plugin Author Matt Keys

    (@mattkeys)

    Hey @jbusch @mojamba,

    Sorry you are both having issues accessing the options. I just double checked and it is still working in my own test environment on the latest version of WordPress.

    I have seen other reports like yours over the years, and it usually ends up that there is some plugin, or theme code, that is creating a javascript error on the page. When there is a critical/fatal javascript error on the page it prevents other javascript code from running. In this case the options sections toggle open/closed using javascript.

    If you are familiar with using your browsers developer tools, you should be able to look at the console, and see if there are any errors being reported on the page, which may help track down the source of the issue. Feel free to paste them here and I will do my best to point you in the right direction.

    Hi @mattkeys,
    Thanks for the reply. I’ve checked for Javascript errors but there was nothing above info level messages in the console.

    As a temporary hack/workaround I inspected the code on the ‘+’ button and a few lines down there is <div class="padded hidden">. I removed the hidden class which revealed the option content. I was then able to save my changes.

    I agree that another plugin may be causing the problem. I also suspect jQuery compatibility mode – which this website is using – might also be the cause.

    I’ll continue to investigate.

    • This reply was modified 4 months, 3 weeks ago by jbusch.
    Plugin Author Matt Keys

    (@mattkeys)

    Thanks for the debugging. Please do share any additional clues you uncover.

    I also just checked and cannot see any JS errors in the debug console.

    Hi,
    I have just experienced the same behaviour with one of my sites. In the moment I have activated browser debugging mode and resized it for have more space for analyzing code (and less for webpage preview) ¬°everything magically appeared!

    Could it be something related to style sheets and too big screen resolutions?

    Regards,

    Guillermo

    Plugin Author Matt Keys

    (@mattkeys)

    Hey Guillermo, thanks for adding your experience with this issue. Testing in my own environment I haven’t been able to reproduce the issue at different viewport sizes/breakpoints. And looking at the CSS being applied to that content box, I don’t see any media queries. Is the experience you had reproducible in your environment? If so can you share viewport dimensions where the problem happens?

    Thanks,

    Matt

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.