Support » Plugin: Wordfence Security - Firewall & Malware Scan » Cannot access Option “Wordfence’s terms of use and privacy policy have changed”

  • Resolved Roger

    (@rogerwheatley)


    Hello,

    I can no longer access options (or do anything!) with this plugin.

    Ever since the message:

    Wordfence’s terms of use and privacy policy have changed

    and

    Our Terms of Use and Privacy Policy have changed. To continue using Wordfence, you will need to review and accept the updated Terms of Use and Privacy Policy by clicking Review.

    appeared.

    When I click the “Review” button, nothing happens, and I cannot get rid of this.

    How can I remove the “Review” (that is blocking everything), as clicking it does nothing?

    Thank you.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Roger

    (@rogerwheatley)

    Update…
    After 12 logins, I was able to review and accept, however now the saving of changed options are no longer working.

    Also…
    Removal of all plugins and use of default WP theme does not fix the issue.

    • This reply was modified 1 year, 5 months ago by Roger. Reason: Added more information
    Roger

    (@rogerwheatley)

    A complete bare metal (so to speak) installation, results in the same issue. Wordfence does not work (because the settings cannot be saved – The “Save” button is broken).
    I even tried to edit the options in the database, but saw no place where I could do that.
    Unfortunately I can no longer use or recommend Wordfence to any clients (I’m really unhappy about that as I was recommending it to everyone). And am removing the product from all websites.
    This is sad, very sad, and unfortunate indeed. 🙁

    A little umm, “reactive”, no? This is obviously not a widespread issue otherwise there would be many many complaints noted on this forum.

    I’ve updated to the recent WF on many of my client’s sites without issue, so clearly there is something unique to your site and/or hosting environment that is causing this atypical behaviour.

    Roger

    (@rogerwheatley)

    Thanks @bluebearmedia – On the server I was trying to figure out just now, so I could make sure of a quick fix on others… The complete WP was installed from scratch (no content whatsoever, just bare bones WP). Then Wordfence was the only plugin installed. The “Save Changes” button within the “All Options” section is broken.

    It’s not a mod_security issue (disabled that and tested).
    Not .htaccess, removed settings and tested.
    Not a CSF (Config Server Firewall), disabled that and tested.
    Disabling Cloudflare for public facing does not resolve the issue either.

    Also installed Wordfence on the LAN, clean install, no plugins or content, and the same issue happens.

    This issue happened after the most recent update, approximately a week ago, I think (I don’t log in every day to check, maybe the issue happened even sooner, I’m not 100% sure when this started to happen, because there is no need to keep changing settings). Prior to that all was working.

    Side note: Since the update of the UI (a while back), there have been several issues; almost all related to the “ajax style” interface (some websites were not displaying parts of the UI buttons or Wordfence header widgets), instead of the previous style of form submission buttons, but they were things we could live with, so we stuck with it.

    I only noticed this issue when I needed to create a whitelist entry for one IP address. At first I tried to export the current settings, but the export button didn’t do anything. Then I added the IP address to whitelist, clicked the “Save Changes” button, and that didn’t do anything either.

    I’m cycled through each version – On a bare bones WordPress installation (with no other plugins, and no content), and so far the results for each Wordfence version are:

    6.3.22 – Working. Was able to fully configure and save settings as needed (in the hopes that the updated versions will use the settings).

    7.0.1 – Options link in WP sidebar disappears. Settings no longer visible.
    7.0.2 – Options link in WP sidebar disappears. Settings no longer visible.
    7.0.3 – Options link in WP reappears, but “Save Changes” button in the “All Options” section does not work.
    7.0.4 – The “Save Changes” button in the “All Options” section does not work.
    7.0.5 – The “Save Changes” button in the “All Options” section does not work.

    7.1.5 – The “Save Changes” button in the “All Options” section does not work.
    7.1.1 – The “Save Changes” button in the “All Options” section does not work.
    7.1.2 – The “Save Changes” button in the “All Options” section does not work.
    7.1.3 – The “Save Changes” button in the “All Options” section does not work.
    7.1.4 – The “Save Changes” button in the “All Options” section does not work.
    7.1.5 – The “Save Changes” button in the “All Options” section does not work.
    7.1.6 (Developmental) – The “Save Changes” button in the “All Options” section does not work.

    To save option changes, we need to roll back to version 6.3.22 of Wordfence, make and save the changes, than reinstall the most recent Wordfence version.

    This actually sounds like something I did encounter with new versions of WF on *some* client sites…. it appears WF changed something in their script handling (just a guess) that is creating some sort of conflict as of WF v7 (when they changed to that hideous new interface).

    But the symptoms are as you describe – buttons in the dashboard no longer functioning – not just WF, WP options too.

    The workaround solution was to add the following line to wp-config.php:
    define('CONCATENATE_SCRIPTS', false);

    After this was done, full button functionality in the dashboard returned on the affected sites.

    Note however, this is a kludge – we shouldn’t have to do this – but at least it will allow proper operation until the real solution is found/put in place.

    Roger

    (@rogerwheatley)

    @bluebearmedia I tried the define('CONCATENATE_SCRIPTS', false);
    While it didn’t fix this specific issue, it did cause lots of stuff to display in consule – Which pinpointed more where the issue is. So thanks for that suggestion – YOU ROCK!!!! had you not fired off the snippet, I’d still be playing with the marbles.

    Here’s what I was able to see after adding the snippet to WP config…

    An oh wow moment… Check this out!

    TypeError: $(...).wfselect2 is not a function
    init/<
    https://www.milneconservationratepayers.com/wp-content/plugins/wordfence/js/admin.1527005958.js:437:6
    each
    https://www.milneconservationratepayers.com/wp-includes/js/jquery/jquery.js:2:2879
    each
    https://www.milneconservationratepayers.com/wp-includes/js/jquery/jquery.js:2:844
    init
    https://www.milneconservationratepayers.com/wp-content/plugins/wordfence/js/admin.1527005958.js:431:5
    <anonymous>
    https://www.milneconservationratepayers.com/wp-content/plugins/wordfence/js/admin.1527005958.js:3363:3
    i
    https://www.milneconservationratepayers.com/wp-includes/js/jquery/jquery.js:2:27444
    fireWith
    https://www.milneconservationratepayers.com/wp-includes/js/jquery/jquery.js:2:28213
    ready
    https://www.milneconservationratepayers.com/wp-includes/js/jquery/jquery.js:2:30004
    K
    https://www.milneconservationratepayers.com/wp-includes/js/jquery/jquery.js:2:30366
    s
    https://ajax.cloudflare.com/cdn-cgi/scripts/5ad2c803/cloudflare-static/rocket-loader.min.js:1:8114
    p
    https://ajax.cloudflare.com/cdn-cgi/scripts/5ad2c803/cloudflare-static/rocket-loader.min.js:1:1003
    L</t.prototype.simulateStateAfterDeferScriptsActivation
    https://ajax.cloudflare.com/cdn-cgi/scripts/5ad2c803/cloudflare-static/rocket-loader.min.js:1:7497
    callback
    https://ajax.cloudflare.com/cdn-cgi/scripts/5ad2c803/cloudflare-static/rocket-loader.min.js:1:1939
    D</t.prototype.run
    https://ajax.cloudflare.com/cdn-cgi/scripts/5ad2c803/cloudflare-static/rocket-loader.min.js:1:9327
    m
    https://ajax.cloudflare.com/cdn-cgi/scripts/5ad2c803/cloudflare-static/rocket-loader.min.js:1:1898
    callback
    https://ajax.cloudflare.com/cdn-cgi/scripts/5ad2c803/cloudflare-static/rocket-loader.min.js:1:1775
    D</t.prototype.run
    https://ajax.cloudflare.com/cdn-cgi/scripts/5ad2c803/cloudflare-static/rocket-loader.min.js:1:9327
    D</t.prototype.run/n</<
    https://ajax.cloudflare.com/cdn-cgi/scripts/5ad2c803/cloudflare-static/rocket-loader.min.js:1:9155
    c/<

    The odd part? Cloudflare has been paused! It’s only doing DNS according to their dashboard warning message, I cleared the browser cache, yet it’s still trying to pull resources from Cloudflare?

    When I edited the hosts file on the local workstation, to force the domain to go to a specific IP address, then the issue stopped!

    So it seems there is some issue with Cloudflare even though it has been disabled – Yikes!

    Again, thanks for that CONCATENATE snippet, it illuminated much more!

    Nice! Glad you got it sorted!!

    Hi @rogerwheatley
    I’m glad you managed to get this one sorted out, thanks @bluebearmedia for helping out. I’m going to mark this one as resolved for now.

    Thanks.

    Same problem here.
    Reinstalling the plugin didn’t help.
    define('CONCATENATE_SCRIPTS', false); – didn’t help either…

    At some point I do get to the pop-up window. It seems to load something, with a text like “Tap Allow to continue” and then the pop-up window shuts and everything remains the same.
    Any advice please?

    • This reply was modified 1 year, 5 months ago by zelester.

    @rogerwheatley Could you share what exactly you fixed in the local hosts file to let the Cloudflare run on the local machine?

    Roger

    (@rogerwheatley)

    @zelester

    I added two entries using the following syntax / format:

    # Local machine bypass DNS lookup
    123.456.789.012	domainname.com
    123.456.789.012	www.domainname.com

    In the log run however, I ended up moving away from Cloudflare for this specific domain.

    I hope in some small way this discussion thread, and the input others provided, helps you too.

    Edit: I should make note that this does NOT “…let the Cloudflare run on the local machine…” Cloudflare is an online service providing DNS, CDN, and other services. Cloudflare cannot be run on a local machine.

    • This reply was modified 1 year, 5 months ago by Roger.
    • This reply was modified 1 year, 5 months ago by Roger. Reason: Spelling and additional information

    @rogerwheatley Thanks!

    I had it working though after updating the WP version and some other changes I made in the hosting.

    Yeah, doesn’t work on any of ours either. The last time they had some type of alert like that it didn’t work either… and eventually did randomly. Honestly, whatever coding they are using for this function seems to be a little amiss. (PS — this is with different sites using different templates, etc).

    I had the same problem on all my sites using any desktop browser. (so no update to the plugin has fixed the issue)

    The only way I was able to get through, was by using Safari on my iPad. Only then did I get a response when clicking the button to review.

    HA! I figured out my fix for this. This may be what’s keeping everyone else from working too.

    My problem was mod_security. I have a plugin installed called “Custom Post Type Attachment ( PDF )”

    This had a call to js/jquery.cookie.js which was blocked by mod_security because of the “.cookie” part.

    I found this by using Chrome developer tools (F12) and looking at the error log for the wordfence admin page load.

    Even though this plugin had nothing to do with Wordfence, once I fixed that mod_sec problem, the Wordfence admin page worked properly, and I was able to agree to the new policy.

    Check your dev tools to see if you guys are having the same issue.

    Chuck

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Cannot access Option “Wordfence’s terms of use and privacy policy have changed”’ is closed to new replies.