WordPress.org

Support

Support » Themes and Templates » [Resolved] Cannot access new themes

[Resolved] Cannot access new themes

  • Hi there

    Just opened my first wordpress account, which is being hosted via bluehost. I’ve been trying to change the theme but everytime I try to do a theme search I get the error message ‘an unknown error occurred’. It also happens if I click on ‘featured’, ‘newest’ etc tabs.

    I set wordpress up using simplescripts on bluehost. Is there something I need to set up elsewhere in bluehost?

    Many thanks.

Viewing 15 replies - 1 through 15 (of 34 total)
  • Having the exact same problem here – different hosting company but I can’t search for new themes just like the above poster.

    Don’t know what’s up, but I think it might be that your host disallows some functions. Are there other functions in the dashboard that give you this message? Adding plugins, activating Akismet, do the widgets that give you WP news work?
    Of course you can always search for another theme manually:
    http://wordpress.org/extend/themes/
    And add them manually:
    http://codex.wordpress.org/Using_Themes

    I have the same problem on a fresh install of 2.9.2 on a Linux host. I do have other older versions installed and they seem to be able to load the themes.

    Ok so I add
    define(‘WP_DEBUG’, true);
    into wp-config.php and see the following:
    Notice: unserialize() [function.unserialize]: Error at offset 0 of 401 bytes in /var/www/virtual/xxxxx/wordpress/wp-admin/includes/theme-install.php on line 59

    Looking at that file around line 59 I see that the remote host for the themes API is ‘http://api.wordpress.org/themes/info/1.0/’ which I put into a browser and subsequently receive a 503 Server Busy error.
    I suspect then that this will be a temporary problem.

    Thanks for your replies.

    I am able to install plugins without any problems whatsoever, going directly through the wordpress dashboard. I am hoping that this is a temporary problem, but if anyone else can work it out it will be greatly appreciated.

    In the meantime I will attempt to add some themes manually!

    I am having the same problem with a brand new install and tested all my websites (5+). This needs immediate resolution. I can’t even see any themes to install. Any suggestions for work-arounds?

    esmi

    @esmi

    Forum Moderator

    The manual option is working fine for me so I also recommend doing it that way for now.

    I can do the manual process, but I’ve got a half-dozen clients I set up in the past week who are playing around, setting things up. Is there anywhere I can get a status so I can tell them when they can start trying out themes again?

    Yep, I started getting the same error tonight also. Yesterday I installed a new site with no problem. But tonight I am getting the unknown error on one I just installed a few minutes ago when trying to search for themes via the wp dashboard.

    Same here on a new install – Moderator pointed me to this thread however this doesn’t solve the problem. The problem is that when you try to search themes using any method – no themes display at all and you simply get the error message. Please fix this WordPress.

    new install is giving same error to me

    mrmist

    @mrmist

    Forum Janitor

    Since this is a server-side issue it would affect any searches until the issue is resolved at the API side. I’ve logged a trac error as can’t think of any other way to get it sorted quickly.

    http://core.trac.wordpress.org/ticket/13737

    Yes Moderator pointed to this thread, what was the point in doing that? It does not explain the problem! I have five wordpress installed on different url databases, I have had them runnning for a few years, and I have been able to search for new themes and install automatically!

    But for some reason it now says unknown error! Why does WordPress not bother to explain why this is! It would be very nice if someone took the time to say why this is!

    Again I just tried the new theme search and install function about two minutes ago. But the Error message still comes up! Hmmm !!

Viewing 15 replies - 1 through 15 (of 34 total)
  • The topic ‘[Resolved] Cannot access new themes’ is closed to new replies.
Skip to toolbar