Support » Fixing WordPress » Cannot access dashboard after 5.0 update “No update required”

  • Resolved janicecampbell

    (@janicecampbell)


    Good afternoon—
    Two of my sites updated to 5.0, and I cannot access the dashboard at all. I get a grey screen with a white box containing the message below.

    No Update Required
    Your WordPress database is already up-to-date!
    /Continue

    When I click on “continue,” it takes me back to the home page (same thing for both sites).

    I have read through posts about how to fix things, but for all of them it seems necessary to access the dashboard to tweak plugins or empty a cache. Since I cannot get past this screen, I am stuck and cannot process orders, make posts or edits, or anything. Please help.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • The message implies caching problem.

    Check with your hosting provider and flush all the cache related to the site.

    If any caching plugin installed, login to your site via FTP and rename that plugin’s folder.

    Thank you. I do see a cache in the toolbar atop the page. I tried the “flush all pages” option, but am still getting the same message when I try to get to the dashboard.

    There are also options to purge database cache, or to purge only the page I am on. Should I try one of those?

    Yes, purge database cache, db cache is the first suspect for the error you have.

    Thank you! Before I got to that, I checked with my site host (DreamHost), and they fixed it and added the following tip which might help anyone else who is facing this issue.

    “If this happens again you can login via SSH and in the WP install folder or below you can run this command:
    wp cache flush
    That is a wp-cli command from https://wp-cli.org . Very handy for
    managing WP, by the way.”

    Thank you for your help, @paulwp. I appreciate it!

    I’m glad you got it fixed 🙂 and thank you for taking the time to explain the process, it’s definitely helpful for others.

    THANK YOU for this post. This was the exact problem I had as well.

    Just for reference for future searchers. Sometimes you may need to flush cache on memcache too.

    telnet localhost 11211
    flush_all
    quit

    i totally have not seen my dashboard please help

    mrrich617

    (@mrrich617)

    Thank you. wp-cli is a big help.

    In my case, I did clear Redis, but I had wp-optimize installed to kill some old Transients. Apparently, it was caching the old database update status. Leaving this here, just in case it happens to someone else.

    priyankad17

    (@priyankad17)

    I dont have any cache plugin installed in my plugins directory. Please help

    geniusdevpl

    (@geniusdevpl)

    Some hostings are using additional cache, e.g. opcache.
    You can simple reset it by:
    <?php
    opcache_reset();
    ?>
    There’s also a CLI tool for that: https://github.com/gordalina/cachetool

    Just remember that it will flush a current version of CGI (PHP-FPM). If you use multiple versions of FPM you must flush it separately.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.