WordPress.org

Forums

Cannot access any pages, posts, categories (4 posts)

  1. Robins
    Member
    Posted 5 years ago #

    I and another coworker are setting up a WordPress blog on our organization's website. The intention is to eventually run the whole site off WordPress. Currently, the blog is in a test folder on our server.

    The folder, test has 765 permissions, recursively.

    However, we cannot access a number of key elements of the blog, particularly static Pages. Whenever I try to access a Page, Category, Post, or the Archives, I get the following error:

    Not Found

    The requested URL /test/test3 was not found on this server.

    Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny3 with Suhosin-Patch mod_python/3.3.1 Python/2.5.2 mod_perl/2.0.4 Perl/v5.10.0 Server at Port 80

    Now, I can create a page, using the WordPress interface. If I try to view it, the page does not exist. However, the link to it does exist on the main index page. I cannot access the August archives, in spite of two posts being made, one on 8/28 and one on 8/31. I can see both those posts on the main index page, but when I try to view the page for the individual post, I get another Not Found error. I also cannot edit templates using the WordPress interface, I get the following message: You need to make this file writable before you can save your changes. See the Codex for more information.

    I am assuming that this is a write permissions issue. I have given write permissions to the owner and group for this test folder. I do not want to give write permissions to all others due to security issues. I have even added the mysql user to the group which has write access to this folder. Does WordPress have a user it acts as? Is WordPress simply a "other" user on Unix/Linux systems?

    I am beginning to get the feeling that we would need to upload all static pages through FTP as a write-authorized user. However, this would not solve the issue of the Archives not existing, and visitors not being able to go to the individual page for each posting.

    Can anyone provide any insight?

  2. Samuel B
    moderator
    Posted 5 years ago #

    1st try chmod 755 on all folders
    644 files
    that is secure

    also, reset your permalinks
    admin - settings - permalinks

    You need to make this file writable before you can save your changes

    on some servers you will need to chmod files 666 to use the built in editor - then change back to 644

  3. Robins
    Member
    Posted 5 years ago #

    I can get to the permalinks page. There is no option to reset.

    I did change all the file and directory permissions as you recommended, however I still get the same errors as above when I make a new Page.

    Looks like I'll still be working on this one tomorrow.

    As a note, I am not renting server space. The server sits right behind me.

  4. esmi
    Forum Moderator
    Posted 5 years ago #

    Permalinks: change the setting to the default option.

Topic Closed

This topic has been closed to new replies.

About this Topic