Support » Theme: Storefront » Cannot Access Admin

  • perolf

    (@perolf)


    I just upgraded my Storefront Theme from 2.1.8 to 2.2.1 and now I CANNOT access admin. The site will display but the formating is all wrong and I do NOT have the Category drop down. Also keep getting page not found errors. How can I correct this. Is there anyway to reload 2.1.8? I have 2 other sites that I am not going to upgrade to until I find out what gives here…

    Thanks
    Phil

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter perolf

    (@perolf)

    I looked at another question on the forum and found a link to storefront 2.1.8 and loaded that and all is currently working. The checkout page is not the same but it will work. I hope that Woo lets me know when they find a solution to this.

    Mikey Arce

    (@mikeyarce)

    Automattic Happiness Engineer

    Hi @perolf,

    > I looked at another question on the forum and found a link to storefront 2.1.8 and loaded that and all is currently working. The checkout page is not the same but it will work. I hope that Woo lets me know when they find a solution to this.

    What version of PHP are you on? Version 2.2.1 should work with sites that are on older PHP versions. You might try upgrading to PHP 5.6 or above to see if that fixes some of the issues you are having.

    Thread Starter perolf

    (@perolf)

    My site is on godaddy and the PHP version is 5.4. If I upgrade to 5.6 can I reinstall 5.4 if additional problems rear their ugly head?

    LogoLogics

    (@logologics)

    Hi Perolf,

    Storefront 2.2.1. is a major update and they warned to not update in live sites, first try it on a copy/test site.

    You might want to read this first:
    https://storefront.wordpress.com/2017/05/22/storefront-2-2-0-is-now-available-to-download/

    Normally if you switch to a higher php version you should be able to switch back to a lower one. 5.4 is pretty outdated, all my sites run on 7.2!

    Annie

    LogoLogics

    (@logologics)

    I see that they just pushed a fix for sites running lower than php 5.5:
    https://github.com/woocommerce/storefront/blob/master/changelog.md

    Yep you are not alone in this and it probably is caused by the old php version. Would be time to update that anyway…

    https://wordpress.org/support/topic/php-fatal-error-in-storefront-theme-2-2-0/

    Thread Starter perolf

    (@perolf)

    I will update the PHP tonight.

    FYI For Annie, I just looked at one of my other sites admin and there is the indication to upgrade the Storefront theme to 2.2.1. However, there is NO WARNING that it is a major upgrade and when I did the upgrade there were no other warnings…

    I appreciate the feedback…

    LogoLogics

    (@logologics)

    Hi perolf,

    If I remember correctly this was already shown in the previous major update?

    I would reccomend subscribing to their official Storefront development here:
    https://storefront.wordpress.com/2017/05/22/storefront-2-2-0-is-now-available-to-download/

    That way you get notified by e-mail.
    However, it is always best practice to never update in live sites. I always have a copy in a testfolder and update there. If things go bad, I have not messed up a live site and have time to fix things in test. Only if that goes well, I do the updates on a live site.

    Also always see to it you have backups to roll back to. I use the free All in one migration plugin for that and works like a charme!

    Good luck!
    Annie

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Cannot Access Admin’ is closed to new replies.