Support » Plugin: WooCommerce » cancelled order email missing for customer

  • Resolved lew1s

    (@lew1s)


    Hi,

    I am missing cancelled order email template for customer. There is just for admin.

    Also I am using Loco translate plugin and everytime I update Woocommerce I need to translate all emails in Loco. Can you do something with this?

    Thanks

    Regards
    Mike

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Phil

    (@fullysupportedphil)

    Automattic Happiness Engineer

    @lew1s there is not a “Cancelled” email notification for customers, only the administrator. There is a customer email for refunded orders.

    If you wanted to have an email template for canceled orders, you would need to either use a plugin to add one or make some custom code for your site.

    As for your Loco Translate files, make sure that you are storing the translations in a folder that is safe from updates. The default folder for Loco Translate is /wp-content/languages/loco however you may have changed that.

    Hi, thanks for answer. I have all files in languages/loco but everytime I update woocommerce or Loco the translation of emails is gone.

    Also I can’t see where I can translate woocommerce checkout errors:
    2019-02-01_1112

    I can’t see this in braintree plugin, wordpress, woocommerce. Where can I translate this fields? Should be in woocommerce as is in the code but there isn’t.

    Thanks for help!

    Plugin Support Phil

    (@fullysupportedphil)

    Automattic Happiness Engineer

    I’d recommend checking to make sure your WooCommerce and WordPress language files are up to date. That can be done under the “Dashboard > Updates” section of your wp-admin dashboard. At the bottom of that page, please make sure your language files are updated.

    Once that’s done, open loco translate and the language you have edited. Then use the “Sync” feature in loco translate. That should help.

    If not, there may be a problem with how the Loco Translate plugin is working on your site. At that point, I may recommend checking with their team to see if they have ideas on why their plugin is dropping your customizations.. as it shouldn’t do that.

    As for the Braintree plugin, those fields should all show up for you in loco translate as they are all translatable strings. I’ve just checked myself and these strings to show in Loco Translate:

    Image Link: http://cld.wthms.co/l9P7c5

    Please make sure that you select the “WooCommerce PayPal Powered by Braintree Gateway” plugin under loco translate, and not WooCommerce.

    Yes, that’s what I am doing.
    1. in loco WooCommerce PayPal Powered by Braintree Gateway
    2. choose language
    3. Sync
    4. and now string at all. This is strange. https://www.screencast.com/t/QOnFDYBtmZ

    Plugin Support Phil

    (@fullysupportedphil)

    Automattic Happiness Engineer

    @lew1s – thanks for the follow up. It looks like at some point in one of the updates for the plugin we changed the file that is used for the translations. This explains why my test site (which was configured prior to the change) worked and your site didn’t.

    We’ll need to update the plugin to re-declare all of the strings that can be translated. I don’t have an ETA on when that may happen, so in the meantime you can ask Loco Translate to generate it’s own template.

    To do this, click on the “Create template” option.
    On the following page, have Loco Translate auto create a new template for the plugin. From there you can go back to now add a new language to the plugin (the old language you had will need to be removed as it will still be missing the strings).

    Once you do that you will find it will add a number of new strings.

    Here’s a quick screen capture of the steps:
    Image Link: http://cld.wthms.co/Jm1XNN

    I hope that helps and in the future, we’ll correct this with a plugin update for other users.

    I removed all but don’t see option “new template”

    2019-02-05_1234

    and if I create new language the strings are not there

    Plugin Support Phil

    (@fullysupportedphil)

    Automattic Happiness Engineer

    Since you already have an existing template, click “Edit Template” then delete that template.

    Once you’ve done that, you’ll have the option to create a new template using the steps I mentioned above.

    finally fixed. Thanks!!!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘cancelled order email missing for customer’ is closed to new replies.