• Resolved dailce

    (@dailce)


    Hi, I’ve been testing and it looks like the postal code isn’t fully being entered. So for Canada I will have say L3P 8X2, but in the postal/zip field only the first part is being entered “L3P” NOT “L3P 8X2″… this happens sometimes. Also what I’ve see is the city and postal codes get marked invalid once the plugin populates the fields even though the fields have a value.

    • This topic was modified 4 years, 1 month ago by dailce.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter dailce

    (@dailce)

    I think for the invalid part can be fixed. Once your script add the values to the input fields is there a way to trigger say a change event to the input fields? I think my issue is that the validation isn’t detecting the pasting of your values into the fields.

    edit: I tried
    document.getElementById((f)).value = autoc_value;
    var eventy = new Event(‘change’);
    document.getElementById((f)).dispatchEvent(eventx);

    seems to work but if the fields are invalid and then the address fields get populated then woo still doesn’t reevaluate until you submit. I guess that could be how it’s setup?

    • This reply was modified 4 years ago by dailce.
    • This reply was modified 4 years ago by dailce.
    Plugin Contributor natekinkead

    (@natekinkead)

    Updated to 2.0.4 which should jQuery trigger ‘input’ on the inputs after populating them. Let me know if that helps.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Canada Postal Code’ is closed to new replies.