Support » Plugin: Zendesk Chat » Can you update your plugin to be compatible with PHP 7.0 soon?

  • Resolved NolymitContact

    (@nolymitcontact)


    Our site has been using your plugin – latest version and like it a lot. Now, our site wants to use PHP 7.0. One plugin (SG Optimizer) at this site scanned our site before the updating, and reports this:
    ————————————-
    The following plugins/themes are not compatible with PHP 7.0.
    Zendesk Chat Widget
    ————————————–

    Please let us know when you will put out the new version with compatible with PHP 7.0 . If you will not finish that soon, we will use another chat plugin. PHP 7.0 makes wordpress safer and faster.

    Thanks !

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi, The plugin is already compatible with PHP 7.0 but a fallback class for PHP 4.0 causes code sniffers to detect that it is not. We’ve updated the plugin so that it stops doing so. Thank you for you’re interest on this plugin and I do hope you continue on using it. 🙂

    • This reply was modified 2 years, 7 months ago by  kcasas.
    • This reply was modified 2 years, 7 months ago by  kcasas.
    Plugin Author zendesk_official

    (@zendesk_official)

    Marking as resolved. Please free to leave further comments if you still experience the same issue.

    Hello,

    Thanks for the reply. Our wordpress has your latest version. This plugin checks all plugins in this wordpress application before we update to PHP7. Here are the results done by SG Optimizer today:

    **************************************************
    PHP Config

    This tool will allow you to check if your website is compatible with the recommended by SiteGround PHP version and switch to it with a click. It is highly advisable to keep your WordPress running on the recommended PHP for best security and performance.

    Notice: checking your site for PHP 7.0 compatibility is a time consuming process that depends on the number of active plugins you have on your site. Please, don’t close your browser until the check is completed.

    The following plugins/themes are not compatible with PHP 7.0.
    Zendesk Chat Widget
    See Errors
    FILE: /home/nolymit1/public_html/NolymitSiteDev/wp-content/plugins/zopim-live-chat/includes/JSON.php
    —————————————————————————————————-
    FOUND 0 ERRORS AND 3 WARNINGS AFFECTING 3 LINES
    —————————————————————————————————-
    133 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    795 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    812 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    —————————————————————————————————-

    FILE: /home/nolymit1/public_html/NolymitSiteDev/wp-content/plugins/zopim-live-chat/JSON.php
    ———————————————————————————————-
    FOUND 0 ERRORS AND 3 WARNINGS AFFECTING 3 LINES
    ———————————————————————————————-
    133 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    795 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    812 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ———————————————————————————————-

    End Report 1490204105
    **********************************************

    Please let us know soon. Thanks !

    Hi, I’m also using Siteground and get the same php7 warning messages as NolymitContact. Please could you provide more information regarding this and whether it is safe for us to upgrade to php7, thanks.

    Just to update, I contacted Site Ground technical support and recieved the following response:
    “No, it (Zendesk Chat Plugin) will not work. Some WordPress plugins are not supported on php 7”

    Please can you clarify this, as I’ll need be looking for an alternative plugin thats guaranteed to run on php7, Thanks

    • This reply was modified 2 years, 7 months ago by  JDTravel. Reason: Updated information received from Siteground
    Plugin Author Jose Consador

    (@joseconsador)

    Hi,
    Based on the warnings you provided, you seem to be using an older version of our plugin. The current version is 1.4.7 which was released to address these issues. Would you kindly verify that you are on v1.4.7 ?

    ======================================
    The current version is 1.4.7 which was released to address these issues. Would you kindly verify that you are on v1.4.7 ?
    ========================================
    Yes. We checked this before posting here.

    Plugin Author Jose Consador

    (@joseconsador)

    Hi,
    Upon checking it looks like there was a problem with how we deployed updates to the plugin. The JSON.php file that caused the warnings should no longer be there, it has been moved to the /includes directory of our plugin. For now, you can delete the root JSON.php file and leave /includes/JSON.php and your tests should pass. We will be releasing an update with the correct package soon.

    Thanks for reporting this issue!

    Plugin Author Jose Consador

    (@joseconsador)

    Hi,
    We just released version 1.4.8, that should no longer have the incompatible files.

    Joms

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Can you update your plugin to be compatible with PHP 7.0 soon?’ is closed to new replies.