Support » Plugin: WordPress Importer » Can we fix this depreciated Notice?

  • Notice: wp_get_http is deprecated since version 4.4.0! Use WP_Http instead. in /public_html/rmrs/wp-includes/functions.php on line 3783

    Even though it’s just a notice I think this should be upgraded. Were currently at 4.7 and this notice has been around since 4.4

    You get a notice for each and every post that has been imported. I have an import page 3 screens full of these notices.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter Robert Dall

    (@rdall)

    After importing a 6 year old site I got almost 5000 lines of notices ranging from:

    
    Notice: wp_get_http is deprecated since version 4.4.0! Use WP_Http instead.
    
    Notice: Undefined variable: _menu_item_type in
    
    Notice: Array to string conversion in
    

    Yes the plugin did import properly but that was a heck of a lot of notices for a WordPress core plugin.

    • This reply was modified 4 years, 2 months ago by Robert Dall.

    To fix the error:

    1. Open /wp-content/plugins/wordpress-importer/wordpress-importer.php in your favorite text editor.
    2. go to line #991
    3. replace wp_http with WP_Http::get

    Line #991 should now read:
    $headers = WP_Http::get( $url, $upload['file'] );

    See: reference/classes/wp_http/get/

    Thread Starter Robert Dall

    (@rdall)

    Thanks!

    I was reporting this in hopes it would get fixed in the core plugin.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Can we fix this depreciated Notice?’ is closed to new replies.