Support » Plugins and Hacks » Can we fix batch-categories?

Can we fix batch-categories?

  • I just got this from Batch-Categories page:

    # Steph Says:
    February 21st, 2005 at 8:24 am
    I’m really sorry to hear the plugin doesn’t work with 1.5. As I might have mentioned, I’m swamped right now. If nobody does it before me, I’ll adapt it to 1.5 at some point. If anybody feels like doing it, just go ahead! I really don’t care if it’s me or somebody else who writes the 1.5 version of Batch Categories.

    This is such an incredibly valuable tool. Anyone been able to figure out how to get it to work with the new version of WordPress 1.5? I had it working with an earlier beta version, but with the new release, it’s toast and I don’t know what changed to kill it.

    Let’s save batch-categories! Please.

Viewing 15 replies - 1 through 15 (of 52 total)
  • Try adding this just above the admin-header.php require:


    Moderator Ryan Boren


    WordPress Dev


    Some warnings still need to be cleaned up, but it works for me. Put it in your plugin directory and activate. 1.5 only.

    I got a mess of warnings when I activated it, but it says “plugin activated”. And the Batch Categories tab shows up, but the warnings stay. Any way of making them go away? Use the “require_once” mentioned above?

    I’m so thrilled to have this. I’ll see how it is working.

    Here is the error I’m getting and it’s the abbreviated error report and involves the same error for admin.php lines 6, 7, 8, 9. I just don’t know enough about php to nail this and fix it.

    Warning: Cannot modify header information - headers already sent by (output started at /home/cameraon/public_html/test/wordpress/wp-content/plugins/batch-categories.php:402) in /home/cameraon/public_html/test/wordpress/wp-admin/admin.php on line 6

    I’d add the line I specified above to the pre-existing version of batch-categories.php.

    Ryan’s work definitely brings it into the 1.5 era, but I’m playing with the old edition with no errors in Strayhorn on a couple of different setups.

    I did add the:

    above the admin-header.php require add:

    But I can’t find the admin-header.php reference in the batch-categories I grabbed from the above link. I did find:

    global $posts, $post, $wp_query, $id;

    And I put the require above that include, but it didn’t change anything at all. Didn’t hurt or help. Still got the errors.

    It’s annoying but batch-categories is working and I’m plowing through hundreds of screwed up categories. I should have never done a search and replace in the database to change my categories….dumb, but I got what I wanted and now I have to fix the rest.

    Add to this, when I make a change in the Categories Panel (Under Manage), it makes the change but totally chokes. I get an error ridden screen. I had to come back in on a different page and then back to Categories to see that the change had taken place even though it choked. The errors all echo the words “batch-categories”…

    Moderator Ryan Boren


    WordPress Dev

    If you direct your warning message to the server logs (a good practice), they won’t interfere with operation. They need to be fixed, but I haven’t the time at the moment. Consider it groundwork.

    Ah, and how would one do this amazing feat?

    Ah, shoot, do I have to look it up myself again….? 😉

    I’d also love for this to be updated for 1.5


    I’m still waiting to find out how to redirect these warnings to the server logs. HOW?

    Is this an admin plugin in essence? Just helps organise your posts better within the backend?

    “Once more unto the breach?”

    Lorelle: I’m playing with the old edition with no errors in Strayhorn on a couple of different setups. By ‘old edition’ I mean the one from Stephanie’s site. I haven’t put the script through it’s paces as I’ve not much use for it, but the little I’ve played with it caused no problems for me.

    So, I downloaded this:

    Then near the top of the script, changed this:

    $title = __('Batch Categories');
    $parent_file = 'edit.php';


    $title = __('Batch Categories');
    $parent_file = 'edit.php';

    “I know not if the day be ours or no.”

    Hmm Kaf I just tried this – copied and pasted to a new php file, uploaded and had to add the bits to show the plugin within the panel (author name plugin name etc).

    Now I get this error:

    Fatal error: Call to undefined function: get_admin_page_title() in /***/****/public_html/wp/wp-admin/admin-header.php on line 4

    Can I just del the plugin so tht I can get back in the plguins area? I don’t think it’s activated, or has it? Ah bugger.

    Can’t say why that error pops up, since get_admin_page_title() is a WP function, and it’s called to assign $title to the page.

    Don’t activate the plugin from Climb to the Stars, since it’s only meant to provide a link within the admin pages to batch-categories.php.

Viewing 15 replies - 1 through 15 (of 52 total)
  • The topic ‘Can we fix batch-categories?’ is closed to new replies.
Skip to toolbar