Support » Plugin: Compact WP Audio Player » Can this be made compatible with AMP pages?

  • I am testing this on AMP pages using this plugin: https://wordpress.org/plugins/amp/. The plugin shows these errors:

    Invalid script: soundmanager2-nodebug-jsmin.js
     Invalid inline script

    This is the detailed error:

    AMP does not allow the use of JS <script> tags unless they are for loading AMP
    components, which are added automatically by the AMP plugin. For any page to be 
    served as AMP, all invalid script tags must be removed from the page. Instead of 
    custom or third-party JS, please consider using AMP components and functionality 
    such as amp-bind and actions and events (as opposed to JS event handler attributes 
    like onclick). Some custom JS can be added if encapsulated in the amp-script. 
    Learn more about how AMP works.
    
    If all invalid markup is “removed” the page will be served as AMP. However, the 
    impact that the removal has on the page must be assessed to determine if the 
    result is acceptable. If any invalid markup is “kept” then the page will not be 
    served as AMP.
    
    Error code
        DISALLOWED_TAG
    
    Invalid markup
        <script … > 
    
    Element attributes
        type    text/javascript	
        src	    https://*************/wp-content/plugins/compact-wp-audio-player/js/soundmanager2-nodebug-jsmin.js	
        id	    scap.soundmanager2-js
    • This topic was modified 6 months, 2 weeks ago by wrip.
Viewing 1 replies (of 1 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, I have submitted a message to the plugin developers to investigate this issue.

    Thank you

Viewing 1 replies (of 1 total)
  • The topic ‘Can this be made compatible with AMP pages?’ is closed to new replies.