Support » Fixing WordPress » Can someone please help? RSS not working

  • At first I was getting the message “Feed not a registered protocol” whenever I or someone else clicked on RSS. So I changed sidebar.php and footer.php and removed the term “feed” from

    <a>">Entries (RSS)</a>

    But now all I get is some jumbled writing whenever I click on RSS and when I click on Atom it says ftp not loaded properly.

    My site is RSS link is in the sidebar as well as at the footer. Can someone please help?

Viewing 10 replies - 1 through 10 (of 10 total)
  • First of all your links are not correct. You left the “:” from “feed:” in them, which is generating:

    Second, with the correct links your feeds won’t be very readable, as they are in a format designed for syndication, not web browsing. Also, most browsers do not recognise the Atom document type, and will either try to download it, or just ignore it.


    Displays an ad through a bit of host-inserted javascript. This is going to cause problems with validating your feed no matter what.

    Thanks for the input but i’m a fresh newbie. So what do I do about this exactly? I can’t do anything to get rid of that ad I suppose.


    There’s little to suggest here.

    Your host inserts the javascript/ad into every page, which is no doubt part of their service agreement with free hosting. If they allow exclusions (such as for syndication feeds), you’ll have to contact them about it.

    Okay, well I got rid of the javascript ad my host put in there as I upgraded my hosting. However, I still don’t know how to get the RSS link to work. Any suggestions now?

    Site’s at

    Also, RSS link on the right sidebar and the bottom produce different pages? Both don’t work properly.

    what isn’t proper about the link in the right sidebar. Looked like valid xml to me.

    The button at the very bottom of that sidebar is screwed up. What’s the code you have around that one?

    I think there may be a problem with WordPress on this one. Their own rss link at the bottom of this page produces that same error, “Feed not a registered protocol”. Maybe its a firefox thing, but the rss doesn’t work on my blog. Same error. The link looks something like

    WordPress didn’t put the “feed://” prefix on that. The theme author did. Remove it.

    Yep. Look back at my original reply at the top of this thread for what’s left to fix the footer ‘feed’ links.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Can someone please help? RSS not working’ is closed to new replies.