Support » Plugin: Subscribe2 » Can someone check this for me?

  • Resolved callummccormick


    My template for sending new posts to my subscribers follows but it’s not working as expected, the fields {TITLE} and {PERMALINK} are blank when the email is sent.

    I’m using the out-the-box templates, as shown here:

    {BLOGNAME} has posted a new item, '{TITLE}'
    You may view the latest post at
    You received this e-mail because you asked to be notified when new updates are posted.
    Best regards,

Viewing 12 replies - 1 through 12 (of 12 total)
  • @callummccormick,

    Are you using Subscribe2 in per-post or digest (periodic) mode?

    Those two keywords only work in per-post emails so if you are using in digest more you will need to edit the template. Descriptions of all the available keywords are on the same screen as the templates and it will also tell you if they only work for one email type.

    Strange. I’m using this on a per-post hence me scratching my head.

    I have Send Email’s selected as “Once Daily”. Happy to send you screenshot or login if you can assist – I’ll even attempt something radical if you like 🙂



    If you have selected any option in the “Send Emails:” other than “For each Post” then you are sending a digest based periodic notification.

    Perhaps the “For each Post” is a little unclear, it means the post is sent immediately as the publish button is pressed.


    Thanks for trying to help me out. I genuinely appreciate it. I only have 250 subscribers and frankly this isn’t a serious site anyway but I’d like to fix this particular issue.

    May I ask you to just run that past me again please?

    Is there a way I can shoot a screenshot to this place – I’d like to show someone my settings?

    Thanks. Callum.


    You would need to link to your screen shot. Upload it to your server and then post the link here.

    @mattyrob, here it is. Does it look OK?


    As I suspected, on the screen shot you have set the plugin to send emails once a day, that’s a periodic or digest email so keywords like {PERMALINK} and {TITLE} won’t work. Have a look in the Settings page in the Templates tab and in the Keyword descriptions you’ll see which emails the keywords will work for.

    Ah! OK, I’ll sort that today.

    .. and I do this for a living 🙂


    Sometimes it easier to have another set of eyes look over your settings though. 🙂

    OK, I’ve left everything apart from the change here:

    Send Emails:
    + For each Post

    Not tested it – but I guess this is the change I need, OK?

    Thanks Matt.


    Those keywords in the template should be replaced fine now then 😉

    Diamond. Thanks mate. See you next time 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Can someone check this for me?’ is closed to new replies.