Support » Installing WordPress » Can see blog, but get fatal errors when I try to edit/admin

  • Hi there,
    I’ve just installed WP2.2 (first time WP user here), and when I logged in as the admin, I got a Fatal Error message. I should have copied it, but instead I went to the main blog page ( to see if it worked. The blog home page is fine, but when I try to edit the default start entry, I get this error:

    Fatal error: Call to undefined function: wp_reset_vars() in /home/gogstrxn/public_html/blog/wp-admin/post.php on line 7

    If I click on the Site Admin link, I get this error (I suspect this is the one I saw when I first logged in, too):

    Fatal error: Call to undefined function: add_action() in /home/gogstrxn/public_html/blog/wp-admin/index.php on line 16

    I’ve tried re-uploading the files, since that seemed to help with previous Fatal Error problems I found in the forums on a search, but am still getting the same errors. Any ideas what I’ve missed?

Viewing 6 replies - 1 through 6 (of 6 total)
  • whooami



    1st function is defined inside:


    2nd function is defined inside:


    Delete those 2 files off your server, and than upload fresh copies.

    I always suggest to upload a fresh copy of the files – meaning a new download, new unzip, new upload. Files can get corrupted during all the operations above.

    Thanks, I’ll try that and see how I go. Cheers!

    I just deleted the old files, got a new download, new unzip, new upload – and am getting similar errors still.

    Warning: main(admin.php) [function.main]: failed to open stream: No such file or directory in /home/gogstrxn/public_html/blog/wp-admin/post.php on line 2

    Fatal error: main() [function.require]: Failed opening required ‘admin.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/gogstrxn/public_html/blog/wp-admin/post.php on line 2

    Is it something about the way I upload, perhaps? I’m using FileZilla and haven’t had problems previously.




    looks like it might be — you are uploading in ascii mode?

    text files need to be uploaded in ascii
    image files and whatnot get uploaded in binary.

    that error says you dont have a wp-admin/admin.php

    if you dont, you need to upload it.

    if you do, you need to delete the one thats there, and upload a fresh one.

    It was a problem with uploading, as you suggest. Some of the files weren’t uploading at all, and at first I hadn’t understood FileZilla’s way of telling me this 🙂

    In the FileZilla settings, I selected the option for Passive upload, and re-uploaded – this time all files uploaded right away, and I’m not getting any error messages now.

    Thanks whooami and mochi for taking the time to answer – it helps to have someone to talk through the options 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Can see blog, but get fatal errors when I try to edit/admin’ is closed to new replies.