Support » Fixing WordPress » Can only view imported permalinks when logged in

  • I’ve recently imported a blog from Typepad. I had thought everything came across in good shape, but evidently I missed something because, when viewing my archives, I can only view permalinks when I am logged into the site. If I log out and try the same link through the archives, I get the WP 404 error.

    When I change the permalinks to the default value, I can see that there may be problems under the hood, e.g. that link will give me a blank post with 2000+ comments. Yet when I log in and view the same post, I get the correct content with the correct number of comments.

    I have tried deleting and replacing my htaccess file with a blank one, then updating my permalinks. No change in the problem.

    I have tried exporting the posts and importing them into a clean WP install. No change in the problem.

    The problem only exists with the posts that were imported – content created in the new site links correctly.

    Does anyone have any ideas as to what might be going on and how I can correct this?

    Thank you!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi,

    Try to set your desired permalinks settings from wordpress admin area and then add this code in htaccess:

    # BEGIN WordPress

    <IfModule mod_rewrite.c>
    ErrorDocument 404 /index.php?error=404
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    ow, try to access old and new posts.


    Shane G.

    Thanks for the suggestion – unfortunately, that still gives me the same error:

    Not Found

    Apologies, but we were unable to find what you were looking for. Perhaps searching will help.

    What permalink structure are you using?

    Month and name: /%year%/%monthnum%/%postname%/

    Though I’m getting the same results with any of the permalink structures.

    Another observation: if I go to Edit Posts and open an archived item with Quick Edit, then click Update Post, then the link will work correctly, whether logged in or logged out.

    I’ve got 550+ posts in the archives – is there anyway to automatically republish everything?

    And it was as simple as that – all of the imported posts were flagged as drafts (“last modified”), rather than as published. I’m still not sure why excerpts were shown for unpublished drafts on the public archive pages, but mass editing the posts to published status has resolved the linking problem.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Can only view imported permalinks when logged in’ is closed to new replies.