Support » Plugin: Event List » Can only Post Events for Today

  • Resolved sbsads


    I am getting the following error:
    ‘Error: New Event “title” could not be added.’

    After testing, I noticed that I could add events for the current date, but I could neither add events with nor update events to a future date. I’ve looked into the time issue, but cannot seem to track down anything obvious as to why.

    I am able to manually change the date directly within the database, and it will show/display correctly, but under no circumstances can I save events with any future date.

    I tried to go to other Event list plug-ins, but each seems to have its own trouble, and I generally perfer the way yours works. Would love to get it working properly. 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • I really need help with this. I’ve tried to debug, and the system does not even seem to try to insert the new event. I can add a new event if and only if I leave the start date at the default date/time. If I change it in any way, publishing the event fails.

    What would you need from me in order to investigate further?

    I have read other posts where the site-wide date/time settings could be in conflict, but I can’t seem to dial in something that will work.

    What is the trouble?

    Any response would be appreciated.

    Thanks 🙂

    Oh, and I just upgraded to the very latest WP version: 3.8.
    Still no dice. Exactly the same issue.

    This has nearly a 5-star rating. There must be something simple that can be done to correct the issue. :/

    Plugin Author mibuthu


    I know that there are some problems with special date formats but I could not reproduce it until now.

    Please give me the exact date format which is displayed in the new event form.
    Please also give me the PHP version you are using.

    I’m using PHP 5.2.17

    The time format is YYYY/MM/DD when I first come into the “Add New” page. When I edit the date, it becomes YYYY-MM-DD. The date chooser does not allow me to edit the time format.

    If I don’t mess with the date field at all, the event will save. If I change it at all, the event will not save. I attempted to change the Date Format in the General Settings, as suggested in a previous post, but nothing affects the results to this point.

    It looks like you embed the JQuery DatePicker that is in use by WP in general, and perhaps the date validator you use on submission is expecting something different.

    If it helps, this is the compiled line for the date format sent in the form:
    <input type='hidden' id='json_for_js' value='{"el_url":"{ourWebsite}/wp-content\/plugins\/event-list\/","el_date_format":"yy\/mm\/dd"}' />

    Plugin Author mibuthu


    Thanks for the info, I will have a look at it.
    As a workaround you can try to edit line 67 in admin/includes-admin-new.php to
    'el_date_format' => $this->datepicker_format('Y/m/d')));
    This should temporarily fix the problem.

    I changed it to:
    'el_date_format' => $this->datepicker_format(__('Y-m-d'))));

    That did not help, however.

    I did notice something. You have an initial value in the field that defaults to tomorrow and is formatted 2013/12/21. When I click in the field, the calendar pops up, and the date automatically changes to 2013-12-21. I can delete the dashes and retype them, but I cannot type the slashes. The JS validation prevents it.

    I added a mail() line at key points in the process as well, and had the system email me the data submitted. I noticed that the system calls one or the other of extract_date() or extract_date_by_format() three times in the course of saving the data, but I don’t see where it’s called three times. On the successful entries, the extract functions return valid date arrays each time. On the unsuccessful attempts, one of the three will return an empty date array. I think at that point, the script kicks out a false and exits.

    I am curious about the extensive validation procedures for the dates. It seems like a great deal of handling for this data, especially since the form simply fails, dumps the data and returns to the list of events. While I can understand having that were users returned to the form when their date entry did not validate, but it seems that a simpler set of checks might be more useful in this situation, and they would be less prone to encountering trouble in the varied environments users fond themselve (I would expect). What did users run into that make this sort of validation necessary?

    I’m not a master coder, so you probably know something I don’t. Just wondering about the logic behind the code (and maybe I’ll learn something). 😉

    Thanks! 🙂

    Plugin Author mibuthu


    I had a more detailed look at it now but still do not have a solution.
    I tried it with same php-version and same date format without any problems.
    The “el_date_format”:”yy\/mm\/dd” in the hidden field is o.k., so the php-code is working. The problem must be related to the datepicker javascript or in getting the correct date format out of the hidden field.

    Can you please try the following:
    Add the following code after line 15 in admin/js/admin_new.js:

    confirm("json: " + json);
    	confirm("conf.el_date_format: " + conf.el_date_format);

    and post the messages which you will get when you are loading the “New” page.

    Thanks for your help.

    Here is the output:

    json: {"el_url":"http:\/\/\/wdn\/wp-content\/plugins\/event-list\/","el_date_format":"yy\/mm\/dd"}

    conf.el_date_format: yy/mm/dd

    Lines 66, 67 are:

    $json = json_encode(array('el_url'         => EL_URL,
    		                            'el_date_format' => $this->datepicker_format(__('Y/m/d'))));

    I hope that helps. 🙂


    Plugin Author mibuthu


    I really don’t know what’s going on here, all the values are o.k.
    So we can curtail the problem to the jquery datepicker itself.

    There are some more things you can try:

    1. Which browser are you using? Did you also tried another one?

    2. Is only the dateformat setting missing, or do you have this behavior with other settings also? E.g. can you see the 3 month preview if you open the datepicker?

    3. You can try to insert the date format for testing manually:
    Change line 19 in admin/js/admin_new.js to:
    dateFormat: "yy/mm/dd",

    4. You can try an alternative initialization of the date format:
    Add after line 7 in admin/js/admin_new.js:
    $.datepicker.setDefaults({ dateFormat: conf.el_date_format, numberOfMonths: 2 });
    and comment out (“//” at the beginning) the lines 19, 23, 35 and 39:

    //dateFormat: conf.el_date_format,
    //numberOfMonths: 3,


    Please tell me your results.

    Well, none of the above worked, but I did turn the JQ datepicker off. With it off, I was able to enter any data format I needed, and it worked fine. I narrowed the problem to this function in db.php:

    On about line 348 (I entered a couple comments above), the code reads:
    $chars = str_split($format);

    It very strictly parses the data based on the specific format, and fails the date if it does not exactly match, even if it is a valid date. This code seems unnecessary as, with the JQ_datepicker, a valid date format is forced on entry and the date must be converted to ‘Y-m-d’ for saving into the database anyway. I bypassed the function and used only date_parse(), and everything worked perfectly. 🙂

    Line 39 of admin-main.php contributed to the failure as well. It required a date format that was not set by the date settings and differed from the format entered by JQ_datepicker. I changed that format to match what JQdp forced, and the code worked fine then, too.

    It seems to me, though, that the date_parse_from_format() function is entirely unnecessary, as you are not returning a date with a specific format that users must view. You are simply validating the date. Another function returns a formatted date for display, based on data pulled from the db table.

    Those are my thoughts, anyway. Hope that helps. 🙂

    Plugin Author mibuthu


    The initial problem in your case is that the datepicker don’t use the given date format. But I have no idea why.
    There are some other users with date issues and I will do more testing and hopefully find some fixes in one of the next versions.

    Plugin Author mibuthu


    This problem should be fixed since a while.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Can only Post Events for Today’ is closed to new replies.