WordPress.org

Support

Support » Plugins and Hacks » HTML5 jQuery Audio Player » [Resolved] Can only play a single song. Playlist doesn't work!

[Resolved] Can only play a single song. Playlist doesn't work!

  • Ok. Great player so far!

    I’ve added two songs with the correct file paths and wanted to display the playlist but the audio doesn’t play. When I set the same file path of any file directly into the php file and replace your demo file the player works fine. But as soon as I try to add multiple files and show within ‘Manage Songs’ menu and show the playlist, the audio doesn’t play.

    Thanks.

    http://wordpress.org/extend/plugins/html5-jquery-audio-player/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Just tried again. When I add a single song into the playlist the player doesn’t play the track. When I delete it and keep the demo which is directly implemented into the php site, the track gets played.

    Sounds like the files can’t be read (interaction between player/playlist) or like a CHMOD issue maybe?

    Plugin Author Maeve Lander

    @enigmaweb

    Hi chasingpavements, are you able to send a link to your site where the player is embedded so I can check it and try to help?

    Also what browser are you using? I’m wondering if it’s Mime type issue? This can be solved by adding the following lines to your htaccess file:

    AddType audio/ogg ogg
    AddType audio/ogg oga
    AddType video/ogg ogv
    AddType video/mp4 m4v

    Thanks for your answer.

    I already added these types to the htaccess file.
    Here’s the link of the website I’m working on. I’ll delete the link afterwards.

    http://bit.ly/Sep1ll

    Did you have a chance to have a look at the player yet?

    Thank you!

    Plugin Author Maeve Lander

    @enigmaweb

    Ok yep taken a look now…. pretty sure the problem is that you have the player within a table. In my debugger I’ve just pulled the div called “myplayer” out of the table and it works fine. This fixed display issue and the track played properly…

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Can only play a single song. Playlist doesn't work!’ is closed to new replies.
Skip to toolbar